Mailinglist Archive: opensuse-bugs (4037 mails)

< Previous Next >
[Bug 710380] New: Xen: vm-install failed to start
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 4 Aug 2011 14:21:09 +0000
  • Message-id: <bug-710380-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=710380

https://bugzilla.novell.com/show_bug.cgi?id=710380#c0


Summary: Xen: vm-install failed to start
Classification: openSUSE
Product: openSUSE 11.4
Version: Factory
Platform: All
OS/Version: openSUSE 11.4
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Xen
AssignedTo: jdouglas@xxxxxxxxxx
ReportedBy: a@xxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


Created an attachment (id=444182)
--> (http://bugzilla.novell.com/attachment.cgi?id=444182)
rpm -qa -- complete package list

User-Agent: Mozilla/5.0 (X11; Linux i686 (x86_64)) AppleWebKit/535.1
(KHTML, like Gecko) Chrome/15.0.839.0 Safari/535.1 SUSE/15.0.839.0

I installed openSUSE 11.4 KDE x86_64 and later on enabled Xen by clicking on
"Hypervisor und Hilfsprogramme installieren" (Install hypervisor and helper
programs). I selected Xen (and also had the choice to select kvm). I rebooted
into the Xen kernel, and when i now try to run vm-install as root, I get:

ask@ewzw032:~> sudo env LC_ALL=C vm-install
Error: None

"xen-kernel" is installed.

Installed packages which might be of interest:


ask@ewzw032:~> rpm -qa | grep -E 'virt|xen|kernel' | sort ; rpm -q yast2-vm
kernel-default-devel-2.6.37.6-0.7.1.x86_64
kernel-desktop-2.6.37.6-0.7.1.x86_64
kernel-desktop-devel-2.6.37.6-0.7.1.x86_64
kernel-devel-2.6.37.6-0.7.1.noarch
kernel-source-2.6.37.6-0.7.1.noarch
kernel-syms-2.6.37.6-0.7.1.x86_64
kernel-xen-2.6.37.6-0.7.1.x86_64
kernel-xen-devel-2.6.37.6-0.7.1.x86_64
libvirt-0.8.8-0.10.1.x86_64
libvirt-client-0.8.8-0.10.1.x86_64
libvirt-python-0.8.8-0.10.1.x86_64
patterns-openSUSE-devel_kernel-11.4-6.9.1.x86_64
soprano-backend-virtuoso-2.5.63-5.1.x86_64
virt-manager-0.8.5-8.1.x86_64
virtuoso-drivers-6.1.2-4.3.x86_64
virtuoso-server-6.1.2-4.3.x86_64
virt-utils-1.1.5-1.2.1.x86_64
virt-viewer-0.2.1-5.2.x86_64
xen-4.0.2_02-4.9.2.x86_64
xen-libs-4.0.2_02-4.9.2.x86_64
xen-tools-4.0.2_02-4.9.2.x86_64
yast2-vm-2.17.1-3.1.x86_64


Reproducible: Always

Steps to Reproduce:
See above
Actual Results:
nothing, vm-install didn't start - or better, it started, but failed because of
this error message.

Expected Results:
vm-install should work.

Did a little bit of debbugging by adding debug print statements to
/usr/bin/vm-install. I found, that it errors out at line 243:

defaults.connect = vminstall.options.calculate(options, defaults)

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >