Mailinglist Archive: opensuse-bugs (3112 mails)

< Previous Next >
[Bug 703389] New: libv4l needs update to support functions removed from the kernel
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 1 Jul 2011 07:44:46 +0000
  • Message-id: <bug-703389-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=703389

https://bugzilla.novell.com/show_bug.cgi?id=703389#c0


Summary: libv4l needs update to support functions removed from
the kernel
Classification: openSUSE
Product: openSUSE 12.1
Version: Factory
Platform: Other
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Basesystem
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: anixx@xxxxxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; ru; rv:1.9.1.19)
Gecko/20110420 SUSE/2.0.14-2.1 SeaMonkey/2.0.14

As header file linux/videodev.h has been removed from the kernel, all programs
that need this functionality should use libv4l now on, and its header file
libv4l1-videodev.h. But this header is only included in libv4l 8.3 and 8.4,
while current Factory uses version 6.4, the same as in openSUSE 11.4. This
makes building such programs impossible given that the kernel has already been
updated.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >