Mailinglist Archive: opensuse-bugs (4675 mails)

< Previous Next >
[Bug 642289] New: System does not boot correctly with sysvinit-tools-2.88-15.1.x86_64.rpm or newer (blogd issue)
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 28 Sep 2010 13:02:55 +0000
  • Message-id: <bug-642289-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>

https://bugzilla.novell.com/show_bug.cgi?id=642289

https://bugzilla.novell.com/show_bug.cgi?id=642289#c0


Summary: System does not boot correctly with
sysvinit-tools-2.88-15.1.x86_64.rpm or newer (blogd
issue)
Classification: openSUSE
Product: openSUSE 11.4
Version: Factory
Platform: x86-64
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Basesystem
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: vlukas@xxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (compatible; Konqueror/4.5; Linux) KHTML/4.5.1
(like Gecko) SUSE

My system is configured to offer a graphical login screen (kdm) on startup.
After updating to a recent Factory version of Opensuse the boot process does
not continue until reaching graphical login. Instead a login prompt is offered.
The issue does not end there: The system also failed to load the German
keyboard mapping (can be restored manually). When starting KDE manually there
are error messages not shown hitherto (e.g. there is a message that sound
devices could not be found).

After reinstalling some older packages I found that the package
sysvinit-tools-2.88-15.1.x86_64.rpm is the culprit: When I downgrade it to
version sysvinit-tools-2.88-14.1.x86_64.rpm everything works normally.

I tried to narrow the possible origin of the problems down. To that end, I
extracted the binaries from the newer sysvinit-tools and installed them one by
one. I found that having /sbin/blogger and /sbin/blogd from the newer
sysvinit-tools suffices to reproduce the problem. All other binaries can remain
from the older version.

I also went the reverse way. I reinstalled sysvinit-tools-2.88-15.1.x86_64.rpm
(i.e. the newer version). I found that for the problem to go away it is enough
to replace just /sbin/blogd and /sbin/blogger with the older version.

The problem does also happen with sysvinit-tools-2.88-16.1.x86_64.rpm.

From http://lists.opensuse.org/opensuse-commit/2010-08/msg00567.html I see that
indeed there have been changes made to /sbin/blogd and /sbin/blogger. Could
these be the origin of the problems?


Reproducible: Always

Steps to Reproduce:
1. Upgrade the system to a recent Factory revision (e.g. 30 August 2010, or 28
September)

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >