Mailinglist Archive: opensuse-bugs (4671 mails)

< Previous Next >
[Bug 640399] New: "zypper in -t patch timezone-2010l" doesn't find patch
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 19 Sep 2010 15:02:17 +0000
  • Message-id: <bug-640399-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>

https://bugzilla.novell.com/show_bug.cgi?id=640399

https://bugzilla.novell.com/show_bug.cgi?id=640399#c0


Summary: "zypper in -t patch timezone-2010l" doesn't find patch
Classification: openSUSE
Product: openSUSE 11.3
Version: Final
Platform: Other
OS/Version: openSUSE 11.3
Status: NEW
Severity: Normal
Priority: P5 - None
Component: libzypp
AssignedTo: zypp-maintainers@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: suse-beta@xxxxxxxxx
QAContact: qa@xxxxxxx
Found By: Beta-Customer
Blocker: ---


Created an attachment (id=390387)
--> (http://bugzilla.novell.com/attachment.cgi?id=390387)
zypper.log.bz2

zypper lp
Loading repository data...
Reading installed packages...

Repository | Name | Version | Category | Status
--------------+----------------+---------+-------------+-------
Updates [...] | kernel | 3105 | security | needed
Updates [...] | timezone-2010l | 3011 | recommended | needed

zypper in -t patch timezone-2010l
Loading repository data...
Reading installed packages...
Patch 'timezone' not found. <------------
Resolving package dependencies...
Nothing to do.


The reason for this bug is quite obvious when looking at the output above and
also in zypper.log (full log attached):
[zypper] PackageArgs.cc(argsToCaps):239 got wanted 'patch:timezone == 2010l';

Obviously zypper splits the patch name at the "-" and things everything on the
right side is a version number.
There are two options how this bug can be solved:
a) let zypper search for the full name (as given on the commandline) first,
before splitting it into name and version
b) forbid usage of "-" in patch names

BTW: zypper in -t patch timezone-2010l-3011 fails with the same error message.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >