Mailinglist Archive: opensuse-bugs (4661 mails)

< Previous Next >
[Bug 636627] New: Dependencies verification in yast2 does not work
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 2 Sep 2010 12:43:41 +0000
  • Message-id: <bug-636627-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>

https://bugzilla.novell.com/show_bug.cgi?id=636627

https://bugzilla.novell.com/show_bug.cgi?id=636627#c0


Summary: Dependencies verification in yast2 does not work
Classification: openSUSE
Product: openSUSE 11.3
Version: Final
Platform: Other
OS/Version: Other
Status: NEW
Severity: Major
Priority: P5 - None
Component: YaST2
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: msvec@xxxxxxxxxx
QAContact: jsrain@xxxxxxxxxx
Found By: ---
Blocker: ---


When I uninstall a package which breaks dependencies ...

bash# rpm -e libdbusmenu-qt2
error: Failed dependencies:
libdbusmenu-qt.so.2()(64bit) is needed by (installed)
libkde4-4.5.1-293.1.x86_64
libdbusmenu-qt.so.2()(64bit) is needed by (installed)
kdebase4-workspace-4.5.1-494.1.x86_64
bash# rpm -e libdbusmenu-qt2 --nodeps
bash#

.. and ask yast2 package manager (yast2 -i) to check them
(Menu->Dependencies->Check Now), it reports everything is OK.

But obviously it's not, zypper can tell:

bash# zypper verify
The following NEW package is going to be installed:
libdbusmenu-qt2

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >