Mailinglist Archive: opensuse-bugs (4669 mails)

< Previous Next >
[Bug 636118] New: gcc 4.5 breaks mozilla's libffi implementation
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 1 Sep 2010 07:25:54 +0000
  • Message-id: <bug-636118-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>

https://bugzilla.novell.com/show_bug.cgi?id=636118

https://bugzilla.novell.com/show_bug.cgi?id=636118#c0


Summary: gcc 4.5 breaks mozilla's libffi implementation
Classification: openSUSE
Product: openSUSE 11.3
Version: Final
Platform: i586
OS/Version: openSUSE 11.3
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Basesystem
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: wolfgang@xxxxxxxxxxxxx
QAContact: qa@xxxxxxx
Found By: Third Party Developer/Partner
Blocker: ---


Not sure what to do with that but reporting here for reference at least.

Firefox 4 contains a js-ctypes implementation using an internal version of
libffi.
Some operations just fail when compiled with gcc 4.5 on openSUSE 11.3.
(When compiled with 11.2 everything works.)

It only fails for i586 but not x86-64.

Upstream bugreport is here:
https://bugzilla.mozilla.org/show_bug.cgi?id=590683

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >