Mailinglist Archive: opensuse-bugs (4766 mails)

< Previous Next >
[Bug 599380] New: SLE11 build service repository builds RPM unusable on patched SLE11 system
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 23 Apr 2010 20:34:20 +0000
  • Message-id: <bug-599380-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=599380

http://bugzilla.novell.com/show_bug.cgi?id=599380#c0


Summary: SLE11 build service repository builds RPM unusable on
patched SLE11 system
Classification: openSUSE
Product: openSUSE.org
Version: unspecified
Platform: Other
OS/Version: SLED 11
Status: NEW
Severity: Normal
Priority: P5 - None
Component: BuildService
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: john@xxxxxxxxxxxx
QAContact: adrian@xxxxxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.3)
Gecko/20100401 Firefox/3.6.3

The server:proxy project builds 'dansguardian' for SLE_11. This package links
against libclamav, with libclamav.so.5 at the SLE 11 GA.

However, the current libclamav in a patched SLE 11 is libclamav.so.5.

So, you cannot install the 'dansguardian' package from OBS on a patched SLE_11
machine, as libclamav.so.4 is not available.

From an email I was sent by a SLE 11 user:

galois home/fst# rpm -qi clamav
Name : clamav Relocations: (not relocatable)
Version : 0.95.3 Vendor: SUSE LINUX Products
GmbH, Nuernberg, Germany
Release : 0.1.1 Build Date: Fri Oct 30 10:51:11
2009
..
Distribution: SUSE Linux Enterprise 11

galois home/fst# rpm -ql clamav | grep libclamav.so
/usr/lib64/libclamav.so
/usr/lib64/libclamav.so.6
/usr/lib64/libclamav.so.6.0.5

But the dansguardian packages still expect the .5 version:
libclamav.so.5()(64bit) is needed by dansguardian-2.10.1.1-4.1.x86_64
libclamav.so.5(CLAMAV_PUBLIC)(64bit) is needed by
dansguardian-2.10.1.1-4.1.x86_64


Reproducible: Always

Steps to Reproduce:
1.Build a package in OBS for SLE11 that links against libclamav
2.Try to install the resulting package on a fully patched SLE 11 machine

Actual Results:
Package fails to install

Expected Results:
Package installs correctly

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >