Mailinglist Archive: opensuse-bugs (4760 mails)

< Previous Next >
[Bug 597727] libopenssl1_0_0 conflicts with libopenssl0_9_8
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 22 Apr 2010 07:16:17 +0000
  • Message-id: <20100422071617.48585CC69A@xxxxxxxxxxxxxxxxxxxxxx>
http://bugzilla.novell.com/show_bug.cgi?id=597727

http://bugzilla.novell.com/show_bug.cgi?id=597727#c4


--- Comment #4 from Michal Marek <mmarek@xxxxxxxxxx> 2010-04-22 07:16:16 UTC ---
The whole point of the shared library packaging policy
(http://en.opensuse.org/Packaging/Shared_Libraries) is to be able to install
multiple abi versions of the library (to be able to run applications linked
against an older version). In particular, the openssl packaging violates
http://en.opensuse.org/Packaging/Shared_Libraries#Exceptions, point 3:

(3) If a shared library package lib$NAME$NUM must contain other files than
shared libraries for whatever (approved!) reason, their names must be made
unambiguous by putting them in a versioned directory or by versioning their
names to not conflict with the rationale of this policy.

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References