Mailinglist Archive: opensuse-bugs (4760 mails)

< Previous Next >
[Bug 597784] New: weird delay issue in PK zypp backend
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 19 Apr 2010 14:24:20 +0000
  • Message-id: <bug-597784-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=597784

http://bugzilla.novell.com/show_bug.cgi?id=597784#c0


Summary: weird delay issue in PK zypp backend
Classification: openSUSE
Product: openSUSE 11.3
Version: Factory
Platform: x86
OS/Version: Other
Status: NEW
Severity: Major
Priority: P5 - None
Component: libzypp
AssignedTo: zypp-maintainers@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: peter.j.zhu@xxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


Created an attachment (id=355296)
--> (http://bugzilla.novell.com/attachment.cgi?id=355296)
packagekitd daemon log info

User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.9.2.3)
Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)

I got a weird delay issue in PK zypp backend. I'm using PK 0.6.3 in a meego
system

1. pkcon install clutter-gtk-doc, successfully 2. pkcon resolve
clutter-gtk-doc, werid issue comes !!!
It reports nothing!!! The correct behavior should be "Installed
clutter-gtk-doc-0.10.4-1.1.i586 Clutter-Gtk API Reference"
It neither reports "The transaction failed: package-not-found, couldn't find
package"
2. pkcon remove clutter-gtk-doc
It complains "Command failed: This tool couldn't find the installed package:
could not find clutter-gtk-doc"
The more weird thing is that it can resolve and remove successfully after some
time, for example 15 mins. I do nothing during the period. Please see whole
command sequences, corresponding pk_daemon.log with packagekitd --verbose
--disable-timeout and pk_backend_zypp in attachments.


Reproducible: Always

Steps to Reproduce:
[peter@localhost ~]$ pkcon install clutter-gtk-doc
Simulating install [=========================]
Querying [=========================]
Resolving dependencies [=========================]
Installing [=========================]
Waiting for authentication [=========================]
Querying [=========================] for GTK+ and
GNOME
Resolving dependencies [=========================]
Installing packages [=========================]
Querying [=========================]
[peter@localhost ~]$ pkcon resolve clutter-gtk-doc
Resolving [=========================]
Querying [=========================]
[peter@localhost ~]$ pkcon remove clutter-gtk-doc
Command failed: This tool could not find the installed package: could not find
clutter-gtk-doc
[peter@localhost ~]$ pkcon resolve clutter-gtk-doc


Expected Results:
no such delay should happen. I also observe same delay with other operations
like pkcon refresh

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >