Mailinglist Archive: opensuse-bugs (4760 mails)

< Previous Next >
[Bug 597727] New: libopenssl1_0_0 conflicts with libopenssl0_9_8
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 19 Apr 2010 11:30:22 +0000
  • Message-id: <bug-597727-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=597727

http://bugzilla.novell.com/show_bug.cgi?id=597727#c0


Summary: libopenssl1_0_0 conflicts with libopenssl0_9_8
Classification: openSUSE
Product: openSUSE 11.3
Version: Factory
Platform: Other
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Basesystem
AssignedTo: gjhe@xxxxxxxxxx
ReportedBy: mmarek@xxxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


The two packages cannot be installed in parallel, which defeats the purpose of
the shared library packaging policy:
# rpm -ivh libopenssl1_0_0.rpm
Preparing... ########################################### [100%]
file /usr/lib64/engines/lib4758cca.so from install of
libopenssl1_0_0-1.0.0-1.2.x86_64 conflicts with file from package
libopenssl0_9_8-0.9.8k-8.2.x86_64
file /usr/lib64/engines/libaep.so from install of
libopenssl1_0_0-1.0.0-1.2.x86_64 conflicts with file from package
libopenssl0_9_8-0.9.8k-8.2.x86_64
file /usr/lib64/engines/libatalla.so from install of
libopenssl1_0_0-1.0.0-1.2.x86_64 conflicts with file from package
libopenssl0_9_8-0.9.8k-8.2.x86_64
file /usr/lib64/engines/libcapi.so from install of
libopenssl1_0_0-1.0.0-1.2.x86_64 conflicts with file from package
libopenssl0_9_8-0.9.8k-8.2.x86_64
file /usr/lib64/engines/libchil.so from install of
libopenssl1_0_0-1.0.0-1.2.x86_64 conflicts with file from package
libopenssl0_9_8-0.9.8k-8.2.x86_64
file /usr/lib64/engines/libcswift.so from install of
libopenssl1_0_0-1.0.0-1.2.x86_64 conflicts with file from package
libopenssl0_9_8-0.9.8k-8.2.x86_64
file /usr/lib64/engines/libgmp.so from install of
libopenssl1_0_0-1.0.0-1.2.x86_64 conflicts with file from package
libopenssl0_9_8-0.9.8k-8.2.x86_64
file /usr/lib64/engines/libnuron.so from install of
libopenssl1_0_0-1.0.0-1.2.x86_64 conflicts with file from package
libopenssl0_9_8-0.9.8k-8.2.x86_64
file /usr/lib64/engines/libsureware.so from install of
libopenssl1_0_0-1.0.0-1.2.x86_64 conflicts with file from package
libopenssl0_9_8-0.9.8k-8.2.x86_64
file /usr/lib64/engines/libubsec.so from install of
libopenssl1_0_0-1.0.0-1.2.x86_64 conflicts with file from package
libopenssl0_9_8-0.9.8k-8.2.x86_64

Is it possible to use versioned paths here, like
/usr/lib64/openssl-1.0.0/engines/ ?

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >