Mailinglist Archive: opensuse-bugs (4724 mails)

< Previous Next >
[Bug 594250] udev persistent net interface gets renamed on first boot after upgrade
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 12 Apr 2010 20:39:42 +0000
  • Message-id: <20100412203942.5EC7C245467@xxxxxxxxxxxxxxxxxxxxxx>
http://bugzilla.novell.com/show_bug.cgi?id=594250

http://bugzilla.novell.com/show_bug.cgi?id=594250#c7


--- Comment #7 from James Carter <jimc@xxxxxxxxxxxxx> 2010-04-12 20:39:41 UTC
---
@Marius, thanks for the suggestions. The strange thing is, we do add the
update repo when doing the upgrade, and I can prove that the most recently
upgraded machine (where the problem occurred) received
sysconfig-0.72.6-2.5.1.i586 as part of the upgrade and not from a subsequent
online update. After upgrading we verify installation of our special Math
packages and then do update again, and it reports "nothing to do", which is
true.
Also, all but one or two of these machines is being upgraded from SuSE 10.3 and
had 10.1 on it before that, and so the same failure should have occurred on
every one, but it didn't. I have the impression that there are two scripts
that update persistent interface names, but I haven't been able to track down
the second one.
I think that when setting up for an upgrade I'm going to preemptively fix
70-persistent-net.rules and hope that it will not be fixed recursively.
Yes, we do have /etc/udev/rules.d/30-net_persistent_names.rules.disabled on
both affected and unaffected machines, left over from SuSE 10.1 which most of
them had before 10.3.

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References