Mailinglist Archive: opensuse-bugs (4753 mails)

< Previous Next >
[Bug 594812] udev-configure-printer uses "usb/..." device URI for HP printers
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 8 Apr 2010 16:28:07 +0000
  • Message-id: <20100408162807.EB311245520@xxxxxxxxxxxxxxxxxxxxxx>
http://bugzilla.novell.com/show_bug.cgi?id=594812

http://bugzilla.novell.com/show_bug.cgi?id=594812#c2


Johannes Meixner <jsmeix@xxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|NEEDINFO |NEW
InfoProvider|jsmeix@xxxxxxxxxx |

--- Comment #2 from Johannes Meixner <jsmeix@xxxxxxxxxx> 2010-04-08 16:28:07
UTC ---
I noticed this strange message but I wonder
which user runs udev-configure-printer?
Isn't it "root"?
(No other user should be by default allowed to set up a print queue.)

The strange thing is that I can print successfully
via the udev-configure-printer queue (as long as
there is no second queue using the "hp" backend)
and I can also set up and print successfully via queues
using the "hp" backend so that at least for printing the
permissions are sufficient ("lp" has read/write permissions):
----------------------------------------------------------------------
# lsusb | grep LaserJet
Bus 004 Device 003: ID 03f0:0417 Hewlett-Packard LaserJet 1200 series

# ls -l /dev/bus/usb/004/003
crw-rw-r-- 1 root lp 189, 386 2010-04-08 17:20 /dev/bus/usb/004/003
----------------------------------------------------------------------

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References