Mailinglist Archive: opensuse-bugs (4724 mails)

< Previous Next >
[Bug 593119] New: FW: webkit issue crashes Banshee
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 1 Apr 2010 17:33:04 +0000
  • Message-id: <bug-593119-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=593119

http://bugzilla.novell.com/show_bug.cgi?id=593119#c0


Summary: FW: webkit issue crashes Banshee
Classification: openSUSE
Product: openSUSE 11.2
Version: Final
Platform: x86
OS/Version: openSUSE 11.2
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Banshee
AssignedTo: abockover@xxxxxxxxxx
ReportedBy: bruno.r.almeida@xxxxxxxxx
QAContact: abockover@xxxxxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US) AppleWebKit/533.2
(KHTML, like Gecko) Chrome/5.0.342.7 Safari/533.2

This is a forward of Bug 613217 from GNOME's Bugzilla, regarding an openSUSE
specific bug detected in Banshee. There's a problem in the webkit-sharp package
that causes Banshee to crash when the Lyrics and Wikipedia extensions are
enabled. This is still reproducible in the latest Banshee 1.6 release.

https://bugzilla.gnome.org/show_bug.cgi?id=613217

There's a very simple fix that involves editing
/usr/lib/mono/gac/webkit-sharp/1.0.0.0__eaa1d335d2e19745/webkit-sharp.dll.config

<configuration>
<dllmap dll="webkit-1.0" target="webkit-1.0.so.1"/> // it should be
target="webkit-1.0.so.2", instead of .1
</configuration>

Reproducible: Always

Steps to Reproduce:
1. Open Banshee
2. Enable the Lyrics or Wikipedia context pane extensions
Actual Results:
Banshee will crash.

Expected Results:
Lyrics or Wikipedia extensions should be accessible in the context pane.

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
This Thread
  • No further messages