Mailinglist Archive: opensuse-bugs (4691 mails)

< Previous Next >
[Bug 581652] installer should never unset boot flags on otherwise untouched primary partitions
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sat, 27 Feb 2010 07:24:22 +0000
  • Message-id: <20100227072422.ED94CCC7CE@xxxxxxxxxxxxxxxxxxxxxx>
http://bugzilla.novell.com/show_bug.cgi?id=581652

http://bugzilla.novell.com/show_bug.cgi?id=581652#c9


--- Comment #9 from Felix Miata <mrmazda@xxxxxxxxxxxxx> 2010-02-27 07:24:21 UTC
---
Created an attachment (id=345439)
--> (http://bugzilla.novell.com/attachment.cgi?id=345439)
y2logs from new M2 install to /dev/md3

(In reply to comment #8)
If you want to configure GRUB yourself without YaST assistance you can open
yast2-bootloader -> Boot Loader Installation -> Boot Loader: "Do not Install
Any Boot Loader".

I just tried to install again. Apparently I cannot select to install no
bootloader, because if I try to it then refuses to create a menu.lst that the
actual previously installed bootloader needs to find and use for its configfile
stanza for booting M2. I could make my own M2 menu.lst, or an M2 emulation
stanza complete with kernel and initrd lines, but either would have to be
without the benefit of knowing what cmdline options M2 would like used.

So, instead of installing no bootloader, I proceeded by selecting to install
bootloader to custom location, without specifying anything in the typing box
below the custom location checkbox. That succeeded in leaving the boot flag on
the primary partition undisturbed, and left a usable menu.lst in /dev/md3's
/boot/grub/ for use by the actual installed bootloader's configfile stanza
pointing to M2.

Note that if the previous or these y2logs claim installation to /dev/md2, then
there's some other bug with the logging process, as both this and previous M2
installs went to /dev/md3. oS 11.0 lives on /dev/md1, and oS 11.1 lives on
/dev/md2.

This may or may not be related, but installation this time failed to create any
initrd. I kept a copy of the initrd from the previous M2 install, restored it
by booting 11.1, and thus was able to boot the fresh M2 install.

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References