Mailinglist Archive: opensuse-bugs (4691 mails)

< Previous Next >
[Bug 581341] Encrypted swap not allowed unless it is formatted during install
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 23 Feb 2010 17:03:04 +0000
  • Message-id: <20100223170304.2DEBCCC7CE@xxxxxxxxxxxxxxxxxxxxxx>
http://bugzilla.novell.com/show_bug.cgi?id=581341

http://bugzilla.novell.com/show_bug.cgi?id=581341#c3


--- Comment #3 from Thomas Fehr <fehr@xxxxxxxxxx> 2010-02-23 17:03:03 UTC ---
Problem is that when encryption is used we cannot decide a swap partition
from a filesystem partition (Ok on msdos partition table we could use partition
id, but this is not available on GPT disk label, LVM or MD devices).
So we cannot know if mount point "swap" is valid or not in the mount dialog.

The password is asked afterwards so it is also not possible to set up the
dmcrypt device temporarily internally to peek at the filesystem id of the
decrypted volume.

So it is either allowing swap always (which would potentially confuse
users using encrypted non-swap partitions) and potentially recognize later
that the decrypted volume does not contain a swap signature at all and need
to force the user to go back from password screen or have the current behaviour
of forcing encrypted swap to get formatted. Since probably not many people
use encrypted swap with a password anyway I think current behaviour
is still better than allowing "swap" mount point unconditionally for all
encrypted volumes.

Comments?

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References