Mailinglist Archive: opensuse-bugs (4691 mails)

< Previous Next >
[Bug 483136] boot fails with cmdline root=LABEL= syntax (could not find /dev/root)
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 22 Feb 2010 14:01:28 +0000
  • Message-id: <20100222140128.64F54CC7CE@xxxxxxxxxxxxxxxxxxxxxx>
http://bugzilla.novell.com/show_bug.cgi?id=483136

http://bugzilla.novell.com/show_bug.cgi?id=483136#c35


Felix Miata <mrmazda@xxxxxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|NEEDINFO |REOPENED
Info Provider|mrmazda@xxxxxxxxxxxxx |

--- Comment #35 from Felix Miata <mrmazda@xxxxxxxxxxxxx> 2010-02-22 14:01:27
UTC ---
(In reply to comment #32)
Can you boot into the emergency shell again and do the
following:
# mount /dev/md10 /root

The choices here are /dev/md3, /dev/sda10 or /dev/sdb10, the latter two of
which comprise /dev/md3.

$ mount -t ext3 /dev/md3 /root
mount: special device /dev/md3 does not exist

$ mdadm --assemble /dev/md3 /dev/sda10 /dev/sdb10
$ mount -t ext3 /dev/md3 /root
$ rm -f /root/tmp/mkinitrd-debug
$ cat /etc/udev/rules.d/99-mkinitrd-label.rules >/root/root/mkinitrd-debug
$ udevadm info --export-db >/root/root/mkinitrd-debug
$ umount /root
$ ln -s md3 /dev/root
ln: creating symbolic link `/dev/root': File exists
$exit

[apparently normal init]

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >