Mailinglist Archive: opensuse-bugs (4691 mails)

< Previous Next >
[Bug 581612] New: boot.clock blocked for 3 minutes in udevadm settle --seq-start=724 --seq-end=730
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 21 Feb 2010 01:00:50 +0000
  • Message-id: <bug-581612-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=581612

http://bugzilla.novell.com/show_bug.cgi?id=581612#c0


Summary: boot.clock blocked for 3 minutes in udevadm settle
--seq-start=724 --seq-end=730
Classification: openSUSE
Product: openSUSE 11.2
Version: Final
Platform: i586
OS/Version: openSUSE 11.2
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Basesystem
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: phdm@xxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


Created an attachment (id=343674)
--> (http://bugzilla.novell.com/attachment.cgi?id=343674)
boot.msg with added debugging (but udevadm settle debug truncated)

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.7)
Gecko/20091222 SUSE/3.5.7-1.1.1 Firefox/3.5.7

every time I boot opensuse 11.2 on my older machine, it blocks for 3 minutes in
boot.clock. I have investigated and discovered that udevadm settle
--seq-start=724 --seq-end=730 is the culprit : it blocks for 3 minutes.

I have then recompiled udev with added debugging and found thay udevadm settle
os actually busy waiting with a strange behaviour. Logfile is attached.

Reproducible: Always

Steps to Reproduce:
1.(re)boot my old system
2.
3.
Actual Results:
boot process blocked for 3 minutes in boot.clock

Expected Results:
fast boot sequence

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >