Mailinglist Archive: opensuse-bugs (4654 mails)

< Previous Next >
[Bug 577806] New: Intel GMA945 and framebuffer/X.Org
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 7 Feb 2010 22:34:09 +0000
  • Message-id: <bug-577806-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=577806

http://bugzilla.novell.com/show_bug.cgi?id=577806#c0


Summary: Intel GMA945 and framebuffer/X.Org
Classification: openSUSE
Product: openSUSE 11.3
Version: Factory
Platform: x86-64
OS/Version: openSUSE 11.3
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Kernel
AssignedTo: kernel-maintainers@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: lavrinenko_alex@xxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (compatible; Konqueror/4.3) KHTML/4.3.98 (like
Gecko) SUSE

Recent factory update broke automatic intel KMS detect and setup. Booting shows
error:
[ 1.288072] [drm:drm_fill_in_dev] *ERROR* Cannot initialize the agpgart
module.

and screen stays in original vga mode. i915 module loads automatically (with
other modules in deps), but I have to rmmod it and modprobe once again for KMS
to work. /etc/modprobe.d/i915-kms.conf (created by hand) reads:
options i915 modeset=1

Initrd contains every necessary module, /etc/sysconfig/kernel reads:
..
INITRD_MODULES="processor thermal fan edd piix battery i915 drm intel_agp
button video drm_kms_helper i2c_algo_bit"
..

X11 automatic start is not possible since KDM fails due to wrong screen
resolution, so I have to 'rcxdm restart' after I fix framebuffer manually.

Reproducible: Always

Steps to Reproduce:
1.boot on intel gma* machine

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
Follow Ups