Mailinglist Archive: opensuse-bugs (4664 mails)

< Previous Next >
[Bug 576612] New: X11:/XOrg: libvnc.so fails to load because it does not have a vncModuleData data object
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 3 Feb 2010 17:23:50 +0000
  • Message-id: <bug-576612-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=576612

http://bugzilla.novell.com/show_bug.cgi?id=576612#c0


Summary: X11:/XOrg: libvnc.so fails to load because it does not
have a vncModuleData data object
Classification: openSUSE
Product: openSUSE.org
Version: unspecified
Platform: x86-64
OS/Version: openSUSE 11.2
Status: NEW
Severity: Major
Priority: P5 - None
Component: BuildService
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: novell@xxxxxxxxxxxxxxxxxxxx
QAContact: adrian@xxxxxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.0)
Gecko/20100115 SUSE/3.6.0-1.2 Firefox/3.6

Added the http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_11.2/
repository to zypper and ran 'zypper dup' to upgrade (to
xorg-x11-server-7.4-92.3.x86_64)

Now I can no longer use the vnc module.

Relevant lines from Xorg.0.log:

(II) LoadModule: "vnc"
(II) Loading /usr/lib64/xorg/modules/extensions/libvnc.so
(EE) LoadModule: Module vnc does not have a vncModuleData data object.
(II) UnloadModule: "vnc"
(II) Unloading /usr/lib64/xorg/modules/extensions/libvnc.so
(EE) Failed to load module "vnc" (invalid module, 0)



Reproducible: Always

Steps to Reproduce:
1. install xorg-x11-server-7.4-92.3.x86_64
2. add to xorg.conf:

Section "Module"
Load "vnc"
EndSection

3. start X and review errors in Xorg.0.log
Actual Results:
'vnc' module does not load.

Expected Results:
'vnc' module loads successfully.

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >