Mailinglist Archive: opensuse-bugs (6238 mails)

< Previous Next >
[Bug 494958] IPV6_PRIVACY (use_tempaddr) does not work
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 2 Dec 2009 08:43:51 +0000
  • Message-id: <20091202084351.B5326CC7CD@xxxxxxxxxxxxxxxxxxxxxx>

Marius Tomaschewski <mt@xxxxxxxxxx> changed:

What |Removed |Added
Attachment #329830|0 |1
is obsolete| |
Attachment #330351|0 |1
is obsolete| |

--- Comment #20 from Marius Tomaschewski <mt@xxxxxxxxxx> 2009-12-02 08:43:44
UTC ---
Created an attachment (id=330439)
--> (
ifup-sysctl script v2

(In reply to comment #19)
My script was just a quick shot to show what I mean. The second sed was a
copy/paste error (it was late ;) ).

The sed would not replace all "all" substrings ( sed s/all/eth0/g would do
that), and since I grep for a string from the beginning (^) I only replace the
'all' at the beginning.

Yes, it was late yesterday too.

Note: I don't force you to use $INTERFACE -- you can use the interface
name directly. See also the script attached in comment 17 and in this
one -- there is a interface independent ifsysctl file now and the global
/etc/sysctl.conf can be applied as well.

Regarding ifup and NetworkManager:
If I add an interface via vconfig, it uses the value of
"net.ipv6.conf.default.use_tempaddr" - so it works here.

Well, any new interface makes use of the default -- when the default is
already applied. This is the case, because boot.sysctl script runs before
network where any virtual interfaces are created.
This is not the case for physical interfaces that are created earlier and
why we need a fix.
But this special problem can be solved using a PRE_UP_SCRIPT as well - at
least for the ifup / NM=no case (I'm bad and don't care about NM in worst
case ;-).

The point is different:
sysconfig needs per-interface settings and has to provide this (complete,
not only a fix for this bug) functionality anyway, e.g. to disable ipv6 or
autoconfig only on a particular interface (e.g. on a bridge port) or set
another settings required in some setups.
It makes sense to combine a bug fix for this issue and this requirement.

I can provide this script as new feature for 11.3 only and ignore this bug,
but because it is very useful and avoids the need of user hacks also on 11.x,
we can _try_ to provide it earlier as update - it may still get rejected by
the maintenance team.

The execution of the script is not really related to if-up, but to udev,
or am I wrong?

Well... udev yes and no, because it is net subsystem (=ifup/NM) related.

Configure bugmail:
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >