Mailinglist Archive: opensuse-bugs (6605 mails)

< Previous Next >
[Bug 533160] New: Firefox crash when closing tab with .pdf displayed with Adobe Reader plugin
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 21 Aug 2009 00:27:42 -0600
  • Message-id: <bug-533160-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=533160


Summary: Firefox crash when closing tab with .pdf displayed
with Adobe Reader plugin
Classification: openSUSE
Product: openSUSE 11.2
Version: Milestone 5
Platform: x86-64
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Firefox
AssignedTo: bnc-team-mozilla@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: silviu_marin-caea@xxxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---


User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.2)
Gecko/20090730 SUSE/3.5.2-2.4 Firefox/3.5.2

These errors appear in the console, starting with Gdk-ERROR:

firefox
*** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB to
enable).
ERROR: ld.so: object
'/usr/lib/Adobe/Reader8/Reader/intellinux/lib/suse-do-not-grab-server.so' from
LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object
'/usr/lib/Adobe/Reader8/Reader/intellinux/lib/suse-do-not-grab-server.so' from
LD_PRELOAD cannot be preloaded: ignored.

Gdk-ERROR **: The program 'firefox' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAccess (attempt to access private resource denied)'.
(Details: serial 8440 error_code 10 request_code 2 minor_code 0)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
/usr/bin/firefox: line 128: 25244 Trace/breakpoint trap $MOZ_PROGRAM "$@"
09:21:56 silviu_marin-caea@silviu:~>
(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003f1 unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003f0 unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003eb unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003de unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003dd unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003ed unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003ec unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003db unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003dc unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003d9 unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003da unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003ef unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003ee unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003d8 unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003f5 unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003f3 unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003f2 unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003d7 unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003d5 unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003f4 unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003d6 unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003d4 unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003d3 unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003d2 unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003ca unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003ce unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003cd unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003cc unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003cb unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003c9 unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003c7 unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x94003c8 unexpectedly destroyed

(acroread:25290): Gdk-WARNING **: GdkWindow 0x9400158 unexpectedly destroyed

(acroread:25290): GLib-GObject-WARNING **: invalid unclassed pointer in cast to
`GtkEntry'

(acroread:25290): Gtk-CRITICAL **: gtk_entry_get_layout: assertion
`GTK_IS_ENTRY (entry)' failed

(acroread:25290): Pango-CRITICAL **: pango_layout_get_pixel_extents: assertion
`PANGO_IS_LAYOUT (layout)' failed

(acroread:25290): GLib-GObject-WARNING **: invalid unclassed pointer in cast to
`GtkEntry'

(acroread:25290): Gtk-CRITICAL **: gtk_entry_get_layout: assertion
`GTK_IS_ENTRY (entry)' failed

(acroread:25290): Pango-CRITICAL **: pango_layout_get_pixel_extents: assertion
`PANGO_IS_LAYOUT (layout)' failed

(acroread:25290): GLib-GObject-WARNING **: invalid unclassed pointer in cast to
`GtkEntry'

(acroread:25290): Gtk-CRITICAL **: gtk_entry_get_layout: assertion
`GTK_IS_ENTRY (entry)' failed

(acroread:25290): Pango-CRITICAL **: pango_layout_get_pixel_extents: assertion
`PANGO_IS_LAYOUT (layout)' failed

(acroread:25290): GLib-GObject-WARNING **: invalid unclassed pointer in cast to
`GtkEntry'

(acroread:25290): Gtk-CRITICAL **: gtk_entry_get_layout: assertion
`GTK_IS_ENTRY (entry)' failed

(acroread:25290): Pango-CRITICAL **: pango_layout_get_pixel_extents: assertion
`PANGO_IS_LAYOUT (layout)' failed

(acroread:25290): GLib-GObject-WARNING **: invalid unclassed pointer in cast to
`GtkEntry'

(acroread:25290): Gtk-CRITICAL **: gtk_entry_get_layout: assertion
`GTK_IS_ENTRY (entry)' failed

(acroread:25290): Pango-CRITICAL **: pango_layout_get_pixel_extents: assertion
`PANGO_IS_LAYOUT (layout)' failed

(acroread:25290): GLib-GObject-WARNING **: invalid unclassed pointer in cast to
`GtkEntry'

(acroread:25290): Gtk-CRITICAL **: gtk_entry_get_layout: assertion
`GTK_IS_ENTRY (entry)' failed

(acroread:25290): Pango-CRITICAL **: pango_layout_get_pixel_extents: assertion
`PANGO_IS_LAYOUT (layout)' failed

(acroread:25290): GLib-GObject-WARNING **: invalid unclassed pointer in cast to
`GtkEntry'

(acroread:25290): Gtk-CRITICAL **: gtk_entry_get_layout: assertion
`GTK_IS_ENTRY (entry)' failed


Reproducible: Always

Steps to Reproduce:
1. open .pdf in browser with Adobe Reader plugin acroread-8.1.5-1.5
2. close tab with .pdf
3. firefox crash
Actual Results:
firefox crash

Expected Results:
no crash

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >