Mailinglist Archive: opensuse-bugs (6606 mails)

< Previous Next >
[Bug 528755] New: Package state "Protected -- Do Not Modify" not saved
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 6 Aug 2009 04:04:46 -0600
  • Message-id: <bug-528755-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=528755


Summary: Package state "Protected -- Do Not Modify" not saved
Classification: openSUSE
Product: openSUSE 11.2
Version: Factory
Platform: Other
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: YaST2
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: rkrell@xxxxxxx
QAContact: jsrain@xxxxxxxxxx
Found By: ---


User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.2)
Gecko/20090730 SUSE/3.5.2-1.1 Firefox/3.5.2

I got to report some annoyance in YaST Software installation, not absolutely
sure, whether it is a misunderstanding or a bug:

On marking several packages as Protected, this state has been saved only in one
case, but normally isn't saved. I guess it's intended to save the Protected
state for further calls of the Software Installation tool, isn't it?

Reproducible: Always

Steps to Reproduce:
1. Launch YaST Software installation.
2. Show packages of a repository of your choice
3. Mark several packages as "Protected -- Do Not Modify"
4. (you can do other things there, as mark different packages to be updated)
5. Press Accept button
6. Wait until installation is finished
7. Launch YaST Software installation a second time
8. Go to the same repository as before showing the packages you marked as
Protected before


Actual Results:
The packages marked Protected before are no longer marked Protected.

Expected Results:
The Protected state should be saved on disk and renewed in subsequent
installation sessions.

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >