Mailinglist Archive: opensuse-bugs (6564 mails)

< Previous Next >
[Bug 528359] New: unnecessary blocking on build service ...
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 5 Aug 2009 04:49:57 -0600
  • Message-id: <bug-528359-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=528359


Summary: unnecessary blocking on build service ...
Classification: openSUSE
Product: openSUSE.org
Version: unspecified
Platform: Other
OS/Version: Other
Status: NEW
Severity: Critical
Priority: P5 - None
Component: BuildService
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: mmeeks@xxxxxxxxxx
QAContact: adrian@xxxxxxxxxx
Found By: ---


I have three packages to update; one of them will generate a new package:
libgssdp-devel - but I only just checked this into the build service. However I
want to move on and compile the next package:

[snip]
$ osc build -k /tmp/rpms -p /tmp/rpms --no-verify SLE_11 i586
..
linux-h3ht finished "build gssdp.spec" at Wed Aug 5 11:41:40 BST 2009.


/var/tmp/build-root/usr/src/packages/SRPMS/gssdp-0.6.4-2.src.rpm

/var/tmp/build-root/usr/src/packages/RPMS/i586/libgssdp-devel-0.6.4-2.i586.rpm
/var/tmp/build-root/usr/src/packages/RPMS/i586/gssdp-utils-0.6.4-2.i586.rpm
/var/tmp/build-root/usr/src/packages/RPMS/i586/libgssdp-1_0-1-0.6.4-2.i586.rpm

$ cd ../gupnp
$ osc build -k /tmp/rpms -p /tmp/rpms --no-verify SLE_11 i586
Building gupnp.spec for SLE_11/i586
Getting buildinfo from server
buildinfo is broken... it says:
expansion error: nothing provides libgssdp-devel
[snip]

Now- I assume I have to wait an indeterminate period while obs gets around to
building my package - and (then again) while I try to build the next package up
the hierarchy.

Yet of course the correct package is here locally:

$ ls /tmp/rpms/
gssdp-0.6.4-2.src.rpm gssdp-utils-0.6.4-2.i586.rpm
libgssdp-1_0-1-0.6.4-2.i586.rpm libgssdp-devel-0.6.4-2.i586.rpm

which is pretty silly.


It would (of course) be ideal if the dependency solving was done, or could be
done in the client; even using --no-init doesn't let me avoid the checks.


While I'm here - is there some easy way to get a notification that the build is
done - so I can play some sound / queue the action of "submit next build
request" ?

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >