Mailinglist Archive: opensuse-bugs (4172 mails)

< Previous Next >
[Bug 513034] New: gimp-gap-2.4.0-54.12: array subscript is above array bounds
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 14 Jun 2009 15:30:32 -0600
  • Message-id: <bug-513034-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=513034


Summary: gimp-gap-2.4.0-54.12: array subscript is above array
bounds
Classification: openSUSE
Product: openSUSE 11.2
Version: Factory
Platform: All
OS/Version: openSUSE 11.1
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Other
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: dcb314@xxxxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---


I just tried to build Factory package gimp-gap-2.4.0-54.12
and the build said

gimplastvaldesc.c:476:5: warning: array subscript is above array bounds

The source code is

token_tab[GIMP_LASTVAL_END].token = GIMP_DDESC_END;

but

static GimpLastvalTokenTabType token_tab[GIMP_LASTVAL_END];

Clearly broken code. I agree with the compiler. Suggest code rework.

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >