Mailinglist Archive: opensuse-bugs (13048 mails)

< Previous Next >
[Bug 466431] lpfc module with Emulex Corporation Helios-X LightPulse Fibre Channel Adapter (rev 01) [LP11002] not working
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 27 Jan 2009 05:13:00 -0700 (MST)
  • Message-id: <20090127121300.4653ACC7D4@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=466431

User kristjan.eentsalu@xxxxxx added comment
https://bugzilla.novell.com/show_bug.cgi?id=466431#c11





--- Comment #11 from Kristjan Eentsalu <kristjan.eentsalu@xxxxxx> 2009-01-27
05:12:58 MST ---
Hello

new firmware version is 2.80a4



Made the changes in lpfc_sli.c, compiled the module and loaded it, it still
failed, this time without "Adapter failed to set maximum DMA length
mbxStatus"(because I removed this part) message so this problem is not related
to lpfc_sli_set_dma_length

Also took new lpfc driver from kernel 2.6.28.2(this is also without
lpfc_sli_set_dma_length ) compiled it and during load time it also failed

output of "insmod drivers/scsi/lpfc/lpfc.ko lpfc_log_verbose=0xffff"

see attachment 828.txt


Then I took the lpfc driver(v: 8.2.7) from kernel linux-2.6.27.5, compiled it
and it loaded i can see the luns and mount the partitions

compile warnings:

CC [M] drivers/scsi/lpfc/lpfc_mem.o
CC [M] drivers/scsi/lpfc/lpfc_sli.o
drivers/scsi/lpfc/lpfc_sli.c: In function ‘lpfc_sli_poll_fcp_ring’:
drivers/scsi/lpfc/lpfc_sli.c:1365: warning: array subscript is above array
bounds
drivers/scsi/lpfc/lpfc_sli.c:1365: warning: array subscript is above array
bounds
drivers/scsi/lpfc/lpfc_sli.c: In function ‘lpfc_sli_handle_fast_ring_event’:
drivers/scsi/lpfc/lpfc_sli.c:1541: warning: array subscript is above array
bounds
drivers/scsi/lpfc/lpfc_sli.c:1541: warning: array subscript is above array
bounds
CC [M] drivers/scsi/lpfc/lpfc_ct.o
CC [M] drivers/scsi/lpfc/lpfc_els.o
CC [M] drivers/scsi/lpfc/lpfc_hbadisc.o
CC [M] drivers/scsi/lpfc/lpfc_init.o
CC [M] drivers/scsi/lpfc/lpfc_mbox.o
CC [M] drivers/scsi/lpfc/lpfc_nportdisc.o
CC [M] drivers/scsi/lpfc/lpfc_scsi.o
drivers/scsi/lpfc/lpfc_scsi.c: In function ‘lpfc_bus_reset_handler’:
drivers/scsi/lpfc/lpfc_scsi.c:1245: warning: ‘status’ may be used uninitialized
in this function
CC [M] drivers/scsi/lpfc/lpfc_attr.o
CC [M] drivers/scsi/lpfc/lpfc_vport.o
CC [M] drivers/scsi/lpfc/lpfc_debugfs.o
LD [M] drivers/scsi/lpfc/lpfc.o
Building modules, stage 2.
MODPOST 1 modules
CC drivers/scsi/lpfc/lpfc.mod.o
LD [M] drivers/scsi/lpfc/lpfc.ko



and then output of "insmod drivers/scsi/lpfc/lpfc.ko lpfc_log_verbose=0xffff"



see attachment 827.txt



I took the kernels from kernel.org


Also I have similiar machine with the same HBA(fw version 2.10a10), I popped in
the OpenSuse11.1 cd and during boot I saw the same errors when lpfc module was
loading



Kristjan

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
< Previous Next >
References