Mailinglist Archive: opensuse-bugs (12871 mails)

< Previous Next >
[Bug 462639] access permissions for scsi scanners missing
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 22 Jan 2009 09:18:51 -0700 (MST)
  • Message-id: <20090122161851.63E1ACC7CD@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=462639

User jsmeix@xxxxxxxxxx added comment
https://bugzilla.novell.com/show_bug.cgi?id=462639#c33





--- Comment #33 from Johannes Meixner <jsmeix@xxxxxxxxxx> 2009-01-22 09:18:50
MST ---
I know about the "processor" stuff, just have a look at
/usr/lib/YaST2/bin/test_and_set_scanner_access_permissions

I implemented generic(!) code to handle just this case
for all SCSI "processor"-scanners (and not only
for a few known models via a hardcoded list).

This had worked all the time in the past
and in particular it had worked perfectly
for me when I had implemented and tested it
with such a SCSI "processor"-scanner
(which I currently no longer have available).

Here I do not understand why it does not work when
the "scanner" capability is already known to HAL
for your SCSI scanner regardless which SCSI type
this SCSI scanner has.

According to attachment #264373
HAL already knows that this SCSI device is a "scanner"
but I wonder why because it is a SCSI "processor"
so that HAL should not know it as a "scanner"
so that my code should write an entry for it
to 80-scanner.fdi but it doesn't because
HAL already knows it as a "scanner".

Dieter,
could you therefore please attach the output of
lshal
when this SCSI scanner is connected so that
I might understand what is actually wrong here
so that I could hopefully find and fix the real
root cause of the issue.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >