Mailinglist Archive: opensuse-bugs (12986 mails)

< Previous Next >
[Bug 466484] New: on shutdown the home-partition does not clearly unmount.
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 15 Jan 2009 10:00:37 -0700 (MST)
  • Message-id: <bug-466484-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=466484


Summary: on shutdown the home-partition does not clearly
unmount.
Classification: openSUSE
Product: openSUSE 11.1
Version: Final
Platform: x86-64
OS/Version: openSUSE 11.1
Status: NEW
Severity: Critical
Priority: P5 - None
Component: Other
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: svenzielke@xxxxxx
QAContact: qa@xxxxxxx
Found By: ---


Sorry for my English!
Often some applications accesses the /home-partition (if it exists) and so
unmounting on shutdown fails.
Solutions seems to be moving the follwing block

echo "Sending all processes the TERM signal..."
killall5 -15
echo -e "$rc_done_up"

# wait between last SIGTERM and the next SIGKILL
rc_wait /sbin/blogd /sbin/splash

echo "Sending all processes the KILL signal..."
killall5 -9
echo -e "$rc_done_up"


between

test -s /etc/init.d/.depend.halt || RUN_PARALLEL="no"
type -p startpar &> /dev/null || RUN_PARALLEL="no"
startpar -v &> /dev/null || RUN_PARALLEL="no"


and

#
# set back system boot configuration
#
if test "$RUN_PARALLEL" = "yes" ; then

startopt="-p4 -t 30 -T 3"
eval $(startpar $startopt -M halt)
unset failed_service skipped_service

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >