Mailinglist Archive: opensuse-bugs (13048 mails)

< Previous Next >
[Bug 466431] New: lpfc module with Emulex Corporation Helios-X LightPulse Fibre Channel Adapter (rev 01) [LP11002] not working
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 15 Jan 2009 08:08:48 -0700 (MST)
  • Message-id: <bug-466431-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=466431

User kristjan.eentsalu@xxxxxx added comment
https://bugzilla.novell.com/show_bug.cgi?id=466431#c1

Summary: lpfc module with Emulex Corporation Helios-X
LightPulse Fibre Channel Adapter (rev 01) [LP11002]
not working
Classification: openSUSE
Product: openSUSE 11.1
Version: RC 2
Platform: x86
OS/Version: openSUSE 11.1
Status: NEW
Severity: Critical
Priority: P5 - None
Component: Kernel
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: kristjan.eentsalu@xxxxxx
QAContact: qa@xxxxxxx
Found By: ---


User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5)
Gecko/2008120122 Firefox/3.0.5

During lpfc module load it throws out errors and card does not work.
I loaded the module with options lpfc_log_verbose=0xffff

HBA:

Emulex Corporation Helios-X LightPulse Fibre Channel Adapter (rev 01) [LP11002]

Kernel version:
2.6.27.7-9-pae #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Linux

lpfc module version:

version: 0:8.2.8.7

This is the error:

lpfc 0000:09:06.0: PCI INT A -> GSI 31 (level, low) -> IRQ 31
lpfc 0000:09:06.0: 0:0337 Restart HBA Data: x0 x100
lpfc 0000:09:06.0: 0:0325 Reset HBA Data: x0 x100
lpfc 0000:09:06.0: 0:(0):0309 Mailbox cmd x11 issue Data: x0 x100 x1
lpfc 0000:09:06.0: 0:0462 PCI enable MSI mode success.
lpfc 0000:09:06.0: 0:0337 Restart HBA Data: x0 x100
lpfc 0000:09:06.0: 0:0325 Reset HBA Data: x0 x100
lpfc 0000:09:06.0: 0:(0):0309 Mailbox cmd x11 issue Data: x0 x100 x1
lpfc 0000:09:06.0: 0:0337 Restart HBA Data: x0 x100
lpfc 0000:09:06.0: 0:0325 Reset HBA Data: x0 x100
lpfc 0000:09:06.0: 0:(0):0309 Mailbox cmd x11 issue Data: x0 x100 x1
lpfc 0000:09:06.0: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.0: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.0: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.0: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.0: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.0: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.0: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.0: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.0: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.0: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.0: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.0: 0:0455 Vital Product Data: x82 x21 x0 x48
lpfc 0000:09:06.0: 0:(0):0309 Mailbox cmd x88 issue Data: x0 x100 x1
lpfc 0000:09:06.0: 0:0444 Firmware in SLI 2 mode. Max_vpi 0
lpfc 0000:09:06.0: 0:(0):0309 Mailbox cmd x21 issue Data: x0 x300 x1
lpfc 0000:09:06.0: 0:0:0443 Adapter failed to set maximum DMA length mbxStatus
x0
lpfc 0000:09:06.0: 0:(0):0309 Mailbox cmd x9 issue Data: x0 x300 x1
lpfc 0000:09:06.0: 0:0446 Adapter failed to init (255), mbxCmd x9 CFG_RING,
mbxStatus x0, ring 0
lpfc 0000:09:06.0: 0:0445 Firmware initialization failed
lpfc 0000:09:06.0: 0:1477 Failed to set up hba
lpfc 0000:09:06.0: 0:(0):0248 Cancel Discovery Timer state x0 Data: x80000 x0
x0
lpfc 0000:09:06.0: 0:(0):0248 Cancel Discovery Timer state x0 Data: x80000 x0
x0
lpfc 0000:09:06.0: 0:0337 Restart HBA Data: x0 x200
lpfc 0000:09:06.0: 0:0325 Reset HBA Data: x0 x200
lpfc 0000:09:06.0: 0:0432 Worker thread stopped.
lpfc 0000:09:06.0: PCI INT A disabled
lpfc 0000:09:06.1: PCI INT B -> GSI 34 (level, low) -> IRQ 34
lpfc 0000:09:06.1: 0:0337 Restart HBA Data: x0 x100
lpfc 0000:09:06.1: 0:0325 Reset HBA Data: x0 x100
lpfc 0000:09:06.1: 0:(0):0309 Mailbox cmd x11 issue Data: x0 x100 x1
lpfc 0000:09:06.1: 0:0462 PCI enable MSI mode success.
lpfc 0000:09:06.1: 0:0337 Restart HBA Data: x0 x100
lpfc 0000:09:06.1: 0:0325 Reset HBA Data: x0 x100
lpfc 0000:09:06.1: 0:(0):0309 Mailbox cmd x11 issue Data: x0 x100 x1
lpfc 0000:09:06.1: 0:0337 Restart HBA Data: x0 x100
lpfc 0000:09:06.1: 0:0325 Reset HBA Data: x0 x100
lpfc 0000:09:06.1: 0:(0):0309 Mailbox cmd x11 issue Data: x0 x100 x1
lpfc 0000:09:06.1: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.1: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.1: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.1: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.1: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.1: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.1: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.1: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.1: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.1: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.1: 0:(0):0309 Mailbox cmd x17 issue Data: x0 x100 x1
lpfc 0000:09:06.1: 0:0455 Vital Product Data: x82 x21 x0 x48
lpfc 0000:09:06.1: 0:(0):0309 Mailbox cmd x88 issue Data: x0 x100 x1
lpfc 0000:09:06.1: 0:0444 Firmware in SLI 2 mode. Max_vpi 0
lpfc 0000:09:06.1: 0:(0):0309 Mailbox cmd x21 issue Data: x0 x300 x1
lpfc 0000:09:06.1: 0:0:0443 Adapter failed to set maximum DMA length mbxStatus
x0
lpfc 0000:09:06.1: 0:(0):0309 Mailbox cmd x9 issue Data: x0 x300 x1
lpfc 0000:09:06.1: 0:0446 Adapter failed to init (255), mbxCmd x9 CFG_RING,
mbxStatus x0, ring 0
lpfc 0000:09:06.1: 0:0445 Firmware initialization failed
lpfc 0000:09:06.1: 0:1477 Failed to set up hba
lpfc 0000:09:06.1: 0:(0):0248 Cancel Discovery Timer state x0 Data: x80000 x0
x0
lpfc 0000:09:06.1: 0:(0):0248 Cancel Discovery Timer state x0 Data: x80000 x0
x0
lpfc 0000:09:06.1: 0:0337 Restart HBA Data: x0 x200
lpfc 0000:09:06.1: 0:0325 Reset HBA Data: x0 x200
lpfc 0000:09:06.1: 0:0432 Worker thread stopped.
lpfc 0000:09:06.1: PCI INT B disabled


Also tried it with ubuntu 8.10 and it worked fine, there the lpfc module
version was 8.2.7





Kristjan


Reproducible: Always

Steps to Reproduce:
1. Happens every time when I load lpfc module

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >