Mailinglist Archive: opensuse-bugs (15100 mails)

< Previous Next >
[Bug 325917] ACPI slows down
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 26 Sep 2007 00:39:23 -0600 (MDT)
  • Message-id: <20070926063923.2E51A245269@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=325917#c22


Tejun Heo <teheo@xxxxxxxxxx> changed:

           What    |Removed                                         |Added
----------------------------------------------------------------------------
             Status|NEW                                             |NEEDINFO
      Info Provider|                                                |sragavan@xxxxxxxxxx




--- Comment #22 from Tejun Heo <teheo@xxxxxxxxxx>  2007-09-26 00:39:22 MST ---
libata currently doesn't support configuring transfer mode from userland.  -EIO
failure on 'hdparm -X' is expected.

Also, downgraded transfer speed is result of the problem not the source. 
Without "acpi=off", IRQ routing doesn't work properly and interrupts get lost
from time to time which causes ATA command timeouts.  libata EH think the
timeouts are because of transmission failures on ATA bus and slows down
transfer speed after several timeouts.

So, the root of the problem is flaky IRQ delivery without "acpi=off".  I don't
think ATA is playing any part in causing the problem.

Srinivasa, does "acpi=noirq" fix the problem?


-- 
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References