Mailinglist Archive: opensuse-bugs (6897 mails)

< Previous Next >
[Bug 255677] New: depmod not working! (solved)
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 18 Mar 2007 11:43:11 -0600 (MDT)
  • Message-id: <bug-255677-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=255677

Summary: depmod not working! (solved)
Product: openSUSE 10.2
Version: Final
Platform: x86
OS/Version: Other
Status: NEW
Severity: Major
Priority: P5 - None
Component: Basesystem
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: j.sendler@xxxxxxxxxxx
QAContact: qa@xxxxxxx


Hello, there!


PROBLEM:

I just tried to install OpenSuSE 10.2 via internet (FTP). [D/L March 16, 2007]

All seemed fine, but after reboot, three RAID mounts ("/usr","/home" and one
custom "/backup" partition off the "/" partition) were not mounted, leaving the
system not operational.

It turned out that in the process of that online installation and update, there
was obviously a kernel change from version "2.6.18.8-0.1-default" to version
(back?) "2.6.18.2-34-default".

Unfortunally, the "/lib/modules" directory was not renamed in that process, so
that modules were not loaded properly upon reboot. "depmod" failed with an
error message stating that the apropiate directory was not in place.


SOLUTION:

Simply creating a symlink in the "/lib/modules/" directory ("ln -s
2.6.18.8-0.1-default 2.6.18.2-34-default") solved the issue in a "dirty" way.


SUMMARY:

Ok, this should not happen. - The update process should respect the correct
naming of the module directories. You can either "cleanly" rename the
directory, or, "dirtyly", add a symlink like I did.


==

For Your information: I am a very satisfied customer of SuSE Linux, and have
been since version 4.4.1 (April 1995, kernel 1.0.36). I have since been
involved in several kernel development issues (especially i2c and iptables).
This experience allowed me to solve the reported problem myself.


Thank You for Your attention.


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >