Mailinglist Archive: opensuse-bugs (8119 mails)

< Previous Next >
[Bug 249425] New: filesystem.rpm: LUA dependency?
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 27 Feb 2007 10:32:19 -0700 (MST)
  • Message-id: <bug-249425-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=249425

Summary: filesystem.rpm: LUA dependency?
Product: openSUSE 10.3
Version: Alpha 1
Platform: x86
OS/Version: Linux
Status: NEW
Severity: Minor
Priority: P5 - None
Component: Basesystem
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: jengelh@xxxxxx
QAContact: qa@xxxxxxx


Upgrading from 9.3 to 10.2 using smart or rpm will throw a strange error.

basic93sys# rpm -Uhv filesystem-10.2-22.i586.rpm
error: Failed dependencies:
rpmlib(BuiltinLuaScripts) <= 4.2.2-1 is needed by filesystem-10.2-22

(1) This tells me BuiltinLuaScripts needs to be ... downgraded?!

(2) Why do I need LUA?

$ rpm -qp filesystem-10.2-22.i586.rpm --scripts
preinstall scriptlet (using <lua>):
os.remove ("/usr/include/X11")
os.remove ("/usr/lib/X11")

(3) Is the <= really correct, or should it be >= ?

$ rpm -Rqp filesystem-10.2-22.i586.rpm | grep rpmlib
rpmlib(BuiltinLuaScripts) <= 4.2.2-1

And, on a clean 10.2 install, `rpm -qa --provides | grep rpmlib` does not list
anything - which can't be, can it, given that rpmlib(BuiltinLuaScripts) must be
installed.


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >