Mailinglist Archive: opensuse-bugs (8113 mails)

< Previous Next >
[Bug 225630] rpm segfaults when upgrade a certain security update package.
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 11 Feb 2007 10:30:17 -0700 (MST)
  • Message-id: <20070211173017.B3878FC1@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=225630





------- Comment #9 from robin.listas@xxxxxxxxxxxxxx 2007-02-11 10:30 MST -------
Just for the record.

I solved the database corruption by removing the offending package with rpm -
nothing else worked, not even replacing the database with copies from the
backup. Obviusly, the backups were also corrupt, meaning that the corruption
was old and only manifested itself when trying to touch that part of the
database.

However, even if the crash occurred outside the rpm code, in my opinion, rpm
shouldn't segfault. The error condition should be detected and the program
stopped with a message as helpful as possible.


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >