Mailinglist Archive: opensuse-bugs (8107 mails)

< Previous Next >
[Bug 244457] New: avahi-discover doesn't specify its dependencies correctly
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sat, 10 Feb 2007 09:51:45 -0700 (MST)
  • Message-id: <bug-244457-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=244457

Summary: avahi-discover doesn't specify its dependencies
correctly
Product: openSUSE 10.3
Version: Alpha 0plus
Platform: All
OS/Version: All
Status: NEW
Severity: Normal
Priority: P5 - None
Component: GNOME
AssignedTo: bnc-team-gnome@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: andreas.hanke@xxxxxxxxxxxxxx
QAContact: qa@xxxxxxx


# avahi-discover
Sorry, to use this tool you need to install Avahi, pygtk and python-dbus.
Error: No module named dbus
# echo $?
1

In /usr/bin/avahi-discover I can find:

try:
import avahi, gtk, gobject, dbus, avahi.ServiceTypeDatabase

=> The package that provides avahi-discover needs:

Requires: python-gtk
Requires: dbus-1-python

Otherwise there will be a desktop shortcut to an application that doesn't work.


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >