Mailinglist Archive: opensuse-bugs (8048 mails)

< Previous Next >
[Bug 243007] New: gnome-commander-1.1.7-4 : array subscript is above array bounds
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 7 Feb 2007 03:17:53 -0700 (MST)
  • Message-id: <bug-243007-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=243007

Summary: gnome-commander-1.1.7-4 : array subscript is above array
bounds
Product: openSUSE 10.3
Version: unspecified
Platform: All
OS/Version: SuSE Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: GNOME
AssignedTo: bnc-team-gnome@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: dcb314@xxxxxxxxxxx
QAContact: qa@xxxxxxx


I just tried to compile package gnome-commander-1.1.7-4
with the GNU C compiler version 4.3 snapshot 20070202.

The compiler said

gnome-cmd-advrename-dialog.c:396: warning: array subscript is above array
bounds

The source code is

text[3] = NULL;

but

gchar *text[3];

Suggest code rework.


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >
Follow Ups