Mailinglist Archive: opensuse-bugs (8048 mails)

< Previous Next >
[Bug 242362] New: FlightGear-0.9.10-40: array subscript is above array bounds
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 5 Feb 2007 14:44:32 -0700 (MST)
  • Message-id: <bug-242362-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=242362

Summary: FlightGear-0.9.10-40: array subscript is above array
bounds
Product: openSUSE 10.3
Version: unspecified
Platform: Other
OS/Version: SuSE Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Other
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: dcb314@xxxxxxxxxxx
QAContact: qa@xxxxxxx


I just tried to compile package FlightGear-0.9.10-40
with the GNU C compiler version 4.3 snapshot 20070202.

The compiler said

FGFCS.cpp:80: warning: array subscript is above array bounds

The source code is

for (i=0;i<=NForms;i++) {
DePos[i] = DaLPos[i] = DaRPos[i] = DrPos[i] = 0.0;

but

double DePos[NForms], DaLPos[NForms], DaRPos[NForms], DrPos[NForms];

It looks like an off by one error to me. Suggest code rework.


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >