Mailinglist Archive: opensuse-bugs (8048 mails)

< Previous Next >
[Bug 242270] New: evolution-data-server-1.8.2-15: array subscript is above array bounds
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 5 Feb 2007 10:48:28 -0700 (MST)
  • Message-id: <bug-242270-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=242270

Summary: evolution-data-server-1.8.2-15: array subscript is above
array bounds
Product: openSUSE 10.3
Version: unspecified
Platform: All
OS/Version: SuSE Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Evolution
AssignedTo: kharish@xxxxxxxxxx
ReportedBy: dcb314@xxxxxxxxxxx
QAContact: anagappan@xxxxxxxxxx


I just tried to compile package evolution-data-server-1.8.2-15
with the GNU C compiler version 4.3 snapshot 20070202.

The compiler said

e-gw-item.c:3067: warning: array subscript is above array bounds

The source code is

for (i = 0; i <= max_elements && rrule->by_month [i] !=
E_GW_ITEM_RECUR_END_MARKER; i++) {

Suggest code rework.


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >
Follow Ups