Mailinglist Archive: opensuse-bugs (8956 mails)

< Previous Next >
[Bug 215384] New: Timeout connecting to device when using blktap
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 26 Oct 2006 11:31:07 -0600 (MDT)
  • Message-id: <bug-215384-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=215384

Summary: Timeout connecting to device when using blktap
Product: openSUSE 10.2
Version: Beta 1
Platform: Other
OS/Version: Other
Status: NEW
Severity: Major
Priority: P5 - None
Component: Xen
AssignedTo: jbeulich@xxxxxxxxxx
ReportedBy: jdouglas@xxxxxxxxxx
QAContact: jdouglas@xxxxxxxxxx
CC: ccoffing@xxxxxxxxxx, lbendixs@xxxxxxxxxx


I setup the disks for my VM using blktap. The xen tools do not complain about
the setup, but when the VM boots, it fails to connect to the virtual disk. I
receive the following messages during boot:

<snip>
md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: bitmap version 4.39
NET: Registered protocol family 1
Using IPI No-Shortcut mode
XENBUS: Device with no driver: device/vbd/768
XENBUS: Device with no driver: device/vif/0
Freeing unused kernel memory: 184k freed
Time: xen clocksource has been installed.
Boot logging started on /dev/tty1(/dev/console) at Thu Oct 26 11:17:23 2006
Creating device nodes with udev
udevd[328]: add_to_rules: invalid rule
'/etc/udev/rules.d/71-multipath.rules:20'
Loading xennet
netfront: Initialising virtual ethernet driver.
Loading xenblk
XENBUS: Timeout connecting to device: device/vbd/768 (state 3)
Loading dm-mod
device-mapper: ioctl: 4.7.0-ioctl (2006-06-24) initialised: dm-devel@xxxxxxxxxx
Loading dm-snapshot
Waiting for /dev/mapper/control to appear: ok
Loading jbd
Loading mbcache
mbcache: module not supported by Novell, setting U taint flag.
Loading ext3
no block devices found
/init: line 582: system: command not found
No volume groups found
Waiting for device /dev/system/root to appear:
.............................not found -- exiting to /bin/sh
sh: no job control in this shell

It appears as though the kernel in dom0 is missing support for blktap.


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >