Mailinglist Archive: opensuse-bugs (8956 mails)

< Previous Next >
[Bug 211085] New: {gtk,glib}mm2{,-devel} does not obsolete old package names
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 9 Oct 2006 09:48:38 -0600 (MDT)
  • Message-id: <bug-211085-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>

Summary: {gtk,glib}mm2{,-devel} does not obsolete old package
Product: openSUSE 10.2
Version: Alpha 5
Platform: All
OS/Version: All
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Update Problems
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: andreas.hanke@xxxxxxxxxxxxxx
QAContact: jsrain@xxxxxxxxxx

gtkmm24 has been replaced by gtkmm2
glibmm24 has been replaced by glibmm2
gtkmm24-devel has been replaced by gtkmm2-devel
glibmm24-devel has been replaced by glibmm2-devel

All the new packages are providing the old package name (with version, which is
good). But they are not obsoleting it.

Without the "Obsoletes:" tag, the package manager does not have a hint that
gtkmm2 is actually a newer version of gtkmm24 and that gtkmm24 should be
uninstalled when a gtkmm2 package is available.

But in this particular case, that would be the right thing to do because:

- gtkmm2 is binary compatible with the libraries from gtkmm24
- gtkmm2 and gtkmm24 are not parallel installable, they contain overlapping
- gtkmm24 is orphaned, there will never be a new package with this package name

The tags which should be added are:

Obsoletes: gtkmm24 <= 2.10.1

Obsoletes: gtkmm24-devel <= 2.10.1

Obsoletes: glibmm24 <= 2.12.0

Obsoletes: glibmm24-devel <= 2.12.0

The versions should be written out (i.e. "<= 2.10.1", not "<= %{version}")
because 2.10.1 is the last version that had been packaged under the old gtkmm24
package name.

Configure bugmail:
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >