Mailinglist Archive: opensuse-autoinstall (44 mails)

< Previous Next >
Re: [opensuse-autoinstall] Now lost network woes [Problems with GRUB : sh: /usr/sbin/grub: No such file or directory]
  • From: Simon Loewenthal <simon.loewenthal@xxxxxxxxxxxx>
  • Date: Thu, 15 Jul 2010 11:39:51 +0200
  • Message-id: <4C3ED767.3000102@xxxxxxxxxxxx>
Dear all,

I tried to replicate this error today, but failed, because now half
way through the installation breaks with an error message stating that
it cannot find the installation source (NFS). This makes me think that
the network is being incorrectly configured (or correctly configured by
AutoYast, but is useless for our network).

The checked the DHCP logs on the autoyast server, and only 1 IP is let
out to the client. It does not ask for another one later for the same
NIC nor the second NIC (There are two NICs on the client, although I do
not know whether the second one is cabled up. Remote site and takes a
while for the site management team to check it out).

The network config in the xml file is:
<interfaces config:type="list">
<name>NetXtreme II BCM5708S Gigabit Ethernet</name>

The/etc/dhcpd.conf lets out only the IP

Perhaps, during the install, autoyast decides to use map the second NIC
to eth0, which means it won't find the network. I don't really know
because I have no way of checking. Aborting the install leaves me with
a dead machine.

Thus, is there anyway to make the autoyast xml profile a little more
generic when it comes to settings the NIC? Instead of defining this
below, perhaps one could allow autoyast to stick to the MAC address it
used to boot from. (However I would like to avoid hardcoding the MAC
into the XML file because this sort of defeats the purpose of autoyast)

Any ideas?

-- Once this is solved I can move back to the grub not found problem.

On 07/14/2010 05:47 PM, Simon Loewenthal wrote:
Resent this again to keep the archives useful: The original Subject
header was incorrect.

Dear all,

Its been a while since I autoyasted anything. I just started an
install and was confronted with this message during the end of the

Error while installing GRUB:
sh: /usr/sbin/grub: No such file or directory

I checked the config file (generica-sles11_x84-64-LAMP+Tomcat.xml), for
grub packages and found none. This is strange because these profiles
were used some months ago. It only contains the grub config entry :

I looked in the SLES10 profiles and these contain a package:

Something is amiss, but can anyone spot the mistake?

Best wishes, S.

Simon Loewenthal/Tele2
GSM: +31 6 2000 5427

******** IMPORTANT NOTICE ********
Please repect the X-Reply to PGP available 0x6F54D215
This e-mail (including any attachments) may contain information that is
confidential or otherwise protected from disclosure and it is intended only for
the addressees. If you are not the intended recipient, please note that any
copying, distribution or other use of information contained in this e-mail (and
its attachments) is not allowed. If you have received this e-mail in error,
kindly notify us immediately by telephone or e-mail and delete the message
(including any attachments) from your system.

Please note that e-mail messages may contain computer viruses or other defects,
may not be accurately replicated on other systems, or may be subject of
unauthorized interception or other interference without the knowledge of sender
or recipient. Tele2 only send and receive e-mails on the basis that Tele2 is
not responsible for any such computer viruses, corruption or other interference
or any consequences thereof. It ought to be obvious that my views do not
represent my employer's views.

To unsubscribe, e-mail: opensuse-autoinstall+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-autoinstall+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups