Mailinglist Archive: opensuse-autoinstall (46 mails)

< Previous Next >
Error in autoyast for NLD9
  • From: Wong Onn Chee <ocwong@xxxxxxx>
  • Date: Sat, 9 Jul 2005 14:01:42 +0000 (UTC)
  • Message-id: <42CFD8B1.6050301@xxxxxxx>
Hi,

I have a problem setting up autoyast with NLD9.

I have setup a NLD installation FTP server (ftp://192.168.0.195) running SLES 9. Files from the NLD CDs copied over and setup accordingly. I have also verified that the manual FTP installation works.

Thereafter I create a autoinst.xml file (as attached) from the Autoyast in the NLD client and put in under ftp://192.168.0.195/autoinst.xml with read permissions to all.

Next I try an autoinstallation using the following steps:
1) Boot from NLD Installation Disk 1
2) Choose Installation
3) Add in the options "autoyast=ftp://192.168.0.195/autoinst.xml install=ftp://192.168.0.195";
4) The graphical YaST interface loads and indicates it is starting Autoinstallation.
5) However, at the step where it reads the autoinst.xml, it throws an error saying that the profile for this machine cannot be found and ask me for a new location.

Does anyone have a clue what happened?
Thanks in advance.

Cheers
Onn Chee
<?xml version="1.0"?>
<!DOCTYPE profile SYSTEM "/usr/share/autoinstall/dtd/profile.dtd">
<profile xmlns="http://www.suse.com/1.0/yast2ns"; xmlns:config="http://www.suse.com/1.0/configns";>
<configure>
<files config:type="list">
<file>
<file_contents><![CDATA[It works!]]></file_contents>
<file_owner>root</file_owner>
<file_path>/root/Desktop/test.txt</file_path>
<file_permissions>0700</file_permissions>
</file>
</files>
<networking>
<dns>
<dhcp_hostname config:type="boolean">false</dhcp_hostname>
<dhcp_resolv config:type="boolean">false</dhcp_resolv>
</dns>
<interfaces config:type="list">
<interface>
<bootproto>dhcp</bootproto>
<device>eth0</device>
<startmode>onboot</startmode>
</interface>
</interfaces>
<modules config:type="list">
<module_entry>
<device>static-0</device>
<module></module>
<options></options>
</module_entry>
</modules>
<routing>
<ip_forward config:type="boolean">false</ip_forward>
</routing>
</networking>
<x11>
<color_depth config:type="integer">8</color_depth>
<configure_x11 config:type="boolean">true</configure_x11>
<display_manager>gdm</display_manager>
<enable_3d config:type="boolean">true</enable_3d>
<monitor>
<display>
<frequency config:type="integer">75</frequency>
<height config:type="integer">768</height>
<width config:type="integer">1024</width>
</display>
<monitor_device>1024X768@75HZ</monitor_device>
<monitor_vendor> VESA</monitor_vendor>
</monitor>
<resolution>1024x768</resolution>
<window_manager>gnome</window_manager>
</x11>
</configure>
<install>
<general>
<clock>
<hwclock>localtime</hwclock>
<timezone>America/Los_Angeles</timezone>
</clock>
<keyboard>
<keymap>english-us</keymap>
</keyboard>
<language>en_US</language>
<mode>
<confirm config:type="boolean">false</confirm>
<forceboot config:type="boolean">false</forceboot>
</mode>
<mouse>
<id>probe</id>
</mouse>
</general>
<partitioning config:type="list">
<drive>
<device>/dev/hda</device>
<initialize config:type="boolean">false</initialize>
<partitions config:type="list">
<partition>
<crypt>twofish256</crypt>
<filesystem config:type="symbol">reiser</filesystem>
<format config:type="boolean">true</format>
<loop_fs config:type="boolean">false</loop_fs>
<mount>/boot</mount>
<partition_id config:type="integer">131</partition_id>
<size>100MB</size>
</partition>
<partition>
<crypt>twofish256</crypt>
<filesystem config:type="symbol">swap</filesystem>
<format config:type="boolean">true</format>
<loop_fs config:type="boolean">false</loop_fs>
<mount>swap</mount>
<partition_id config:type="integer">130</partition_id>
<size>1GB</size>
</partition>
<partition>
<crypt>twofish256</crypt>
<filesystem config:type="symbol">reiser</filesystem>
<format config:type="boolean">true</format>
<loop_fs config:type="boolean">false</loop_fs>
<mount>/</mount>
<partition_id config:type="integer">131</partition_id>
<size>max</size>
</partition>
</partitions>
<use>all</use>
</drive>
</partitioning>
<report>
<errors>
<log config:type="boolean">true</log>
<show config:type="boolean">true</show>
<timeout config:type="integer">3</timeout>
</errors>
<messages>
<log config:type="boolean">false</log>
<show config:type="boolean">false</show>
<timeout config:type="integer">10</timeout>
</messages>
<warnings>
<log config:type="boolean">false</log>
<show config:type="boolean">false</show>
<timeout config:type="integer">10</timeout>
</warnings>
<yesno_messages>
<log config:type="boolean">true</log>
<show config:type="boolean">true</show>
<timeout config:type="integer">0</timeout>
</yesno_messages>
</report>
<software>
<addons config:type="list">
<addon>Gnome_Desktop</addon>
<addon>Novell-Software</addon>
<addon>Office</addon>
<addon>SuSE-Documentation</addon>
</addons>
<base>Gnome</base>
<packages config:type="list">
<package>heimdal</package>
<package>heimdal-tools</package>
<package>pam_krb5</package>
</packages>
</software>
</install>
</profile>
< Previous Next >
Follow Ups