Mailinglist Archive: opensuse-autoinstall (120 mails)

< Previous Next >
Re: [suse-autoinstall] RE: SLES 8, PXE, serial console, prompting for CD #1
  • From: Anas Nashif <nashif@xxxxxxx>
  • Date: Wed, 17 Mar 2004 18:04:56 +0000 (UTC)
  • Message-id: <4058933E.8040801@xxxxxxx>
There is NO need to run the create_package_descr command unless you have changed the packages or added any packages.


Andy W. Barclay wrote:
I have no idea on this....

I downloaded the two iso updates, then read the README files on the first CD, and it said nothing about the create_package_descr command.
$ grep create_package * docu/* docu/howto/*

As a matter of fact, the READMEs said nothing about updating an
NFS repository. Was I just looking in the wrong place?

Magnus Hagebris wrote:

1. When you path the installation CD's, don't you have to regenerate the
media list with the create_package_descr command?

On Wed, 2004-03-17 at 08:20, Andy W. Barclay wrote:

I've done some more research and I think I've found out whats going on.

1) The problem with the "Insert UnitedLinux Version 1.0 CD 1" only
happens when I copy the SP3 CD #1 over the distribution.
If I rsync only:
suse linux standard server 8 CD to sles8
united linux CD #1
united linux CD #2
united linux CD #3

then all is well. (except, of course, the lilo thing).
As soon as I copy over:
it starts prompting me.....
I believe the problem is with the media.1/media file, because
if I copy the media.1/media file from the original united linux
CD #1, the thing starts working again.

2) The serial console.
I've found that the order of the parameters is significant.
When I specify "console=ttyS0,9800 console=tty0", it works.
When I specify "console=tty0 console=ttyS0,9800", it doesn't work.

Also, the textmode=1 is extraneous when using a serial console.

3) I've also found a mistake in one of the error messages.
When I boot a machine that has only ide disks and the xml
file refers to /dev/sda, it throws an error (as it should),
but the error says, Partition "/" needs 1224.24 GB more disk
space. I'm pretty sure that should be MB.

Todd Ness wrote:

>> very interesting, here is my pxe entry, I never get a graphical install,
>> and want one.
>> default linux
>> serial 0,9600n8
>> label linux
>> kernel linux
>> append console=ttyS0,9800 console=tty0 load_ramdisk=1 initrd=initrd
>> install=nfs://
>> autoyast=nfs://
>> As far as answering any of your other problems I can not help, but maybe
>> you can get a text install this way. I never get my questions answered.
>> Todd
>> On Tue, 2004-03-16 at 18:41, game82@xxxxxxxxxxxxxx wrote:
>>>>In February, I posted that I was having two problems with the
>>>>autoinstall of SLES8 - I wanted it to not prompt me to confirm
>>>>lilo install, and I wanted it to use text mode.
>>>>The response was to update to SP3 (gets rid of lilo) and to decrease
>>>>the length of the command line (bug).
>>>>Ok, I downloaded the iso images and re-spooled:
>>>>Suse Standard Server 8 (came with the boxed product)
>>>>then tried to install.
>>>>Now, halfway through the install, it prompts me to insert 'UnitedLinux
>>>>Version 1.0' CD 1.
>>>>When I go to the details of the error, it says:
>>>>SuSE Linux AG != SuSE Linux AG
>>>>20031106141452 != 20021022150203
>>>>Ok, so I re-spooled again - this time just the two SP3 iso images and
>>>>re-tried again.
>>>>Same error.
>>>>In addition, I can't seem to get the install to use the serial port as
>>>>a console (all my servers are headless).
>>>>It just doesn't seem to want to do that - here is my pxe entry:
>>>>label suse_standard_server_8
>>>> kernel suseKernel
>>>> append initrd=s textmode=1 console=tty0 console=ttyS0,9600n8
>>>>ramdisk_size=64000 root=/dev/ram3
>>>>Any ideas?

< Previous Next >
Follow Ups