Mailinglist Archive: opensuse-autoinstall (140 mails)

< Previous Next >
Re: [suse-autoinstall] SuSE 8.2 Prof installation of devs-2003.3.14-1 : rm: command not found
  • From: Richard Bos <radoeka@xxxxxxxxx>
  • Date: Mon, 30 Jun 2003 15:23:54 +0000 (UTC)
  • Message-id: <200306301722.01396.radoeka@xxxxxxxxx>
Hello List,

I'm getting the error as listed below (rm: command not found). But as far as
I can determine I've used the dependency file as suggested by Anas below.
What else may be wrong??

linux:~/bin> /usr/tmp/mkautorep82
(equal to: create_package_descr -d /dist/suse82/latest -o
/dist/suse82/latest/setup/descr
using settings:
datadirs: /dist/suse82/latest
languages: english
output dir: /dist/suse82/latest/setup/descr
is not a directory: ignoring
extra_provides: /usr/share/autoinstall/EXTRA_PROV

The packages files has the following information for the coreutils package:
(rm, ln, touch are delivered by coreutils).

========================================
=Pkg: coreutils 4.5.8 12 i586
+Req:
info
/bin/sh
/bin/sh
ld-linux.so.2
libacl.so.1
libacl.so.1(ACL_1.0)
libattr.so.1
libattr.so.1(ATTR_1.1)
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.2)
libc.so.6(GLIBC_2.2.3)
libc.so.6(GLIBC_2.3)
libcrypt.so.1
libdl.so.2
libm.so.6
libm.so.6(GLIBC_2.0)
libpam.so.0
libpthread.so.0
librt.so.1
librt.so.1(GLIBC_2.2)
rpmlib(PayloadIsBzip2) <= 3.0.5-1
-Req:
+Prq:
info
/bin/sh
rpmlib(PayloadIsBzip2) <= 3.0.5-1
-Prq:
+Prv:
fileutil
fileutils
sh-utils
sh_utils
shellutl
stat
textutils
textutl
txtutils
-Prv:
+Obs:
fileutil
fileutils
sh-utils
sh_utils
stat
textutil
textutils
-Obs:
=Grp: System/Base
=Lic: GPL
=Src: coreutils 4.5.8 12 src
=Tim: 1050504269
=Loc: 1 coreutils.rpm
=Siz: 1677871 6069228
========================================

The autoinst.xml file has:
<software>
<base>default</base>
</software>
as software selection.

The coreutils rpm is present:
lrwxrwxrwx 43 2003-06-29 07:34 coreutils.rpm ->
../../base/i586/coreutils-4.5.8-12.i586.rpm

All rpms in the autoinstall repository are links (without version, release or
architecture info) to the most recent version of the package. This does not
seem to be a problem, for the many packages that being installed before the
"devs" package.

Hopefully the solution is around the corner....


Op maandag 16 juni 2003 22:31, schreef Anas Nashif:
> Hi,
>
> Did you by any chance recreate the package database? This happens if
> you have created the database without using the dependency file from
> /usr/share/autoinstall.
>
> Anas
>
> Fred Mobach wrote:
> > Hello List,
> >
> > While my configuration of autoyast in SuSE Linux 8.1 works perfectly an
> > annoying RAID controller in a Dell server forced me to upgrade to 8.2.
> > Normal installation from the SuSE CD's works like a charm. However,
> > autoyast (adapted to the 8.2 rpm's like coreutils) returns errormessages
> > during installation :
> > - SuSE 8.2 Professional via autoyast
> > - installation of devs-2003.3.14-1
> > - Error messages :
> > - var/tmp/rpm-tmp.<PID>: line <n>: rm: command not found
> > (line = 5 and 8)

--
Richard Bos
Without a home the journey is endless


< Previous Next >
Follow Ups