Mailinglist Archive: opensuse-arm (126 mails)

< Previous Next >
[opensuse-arm] OpenSUSE 12.3 for armv7 on Mirabox almost runnning
For anyone who is interested in being able to run openSUSE 12.3 on
Globalscale's Mirabox. Unfortunately I did not succeed...

First I tried with the "standard" mirabox kernel 2.6.35.9 and the rootfs for
openSUSE 12.3 for armv7 (see my previous posts on this mailing list).
That did not work since (as I learned from some people around here,
thanks!) the kernel was too old for openSUSE. So I tried to compile my
own kernel.

I started with 3.9-rc5 and a while later with
3.9-rc6. I did quite some tweaks and twiddeling and finally came up with
this kernel config: http://pastebin.com/MjpE3yUD.
This one does run, you can get into openSUSE, login as root etc., but I
wasn't able to get the network up and running and the USB3 ports
working. Note that my config file disables wifi and bluetooth (I got
some errors and since I do not need it I disabled them).

For the
network, for 3.9-rc6 it seems to run but it cannot connect to "the
outside world" even when I give it a fixed ip address with ifconfig (it
is not able to get an ip address from my dhcp server). The weird thing
is that the MAC addresses openSUSE thinks it has for eth0 and eth1 are
not the MAC addresses which are printed on the mirabox itself.

For
the USB3 ports, I have no clue at all how to get those working. What I
know, is that they are connected to an internal PCIe interface, but I
couldn't find any options to enable it. For me, the USB3 ports are
fundamental since I need to connect an external hard disk to it. I know
it can be done because I have them working using debian 6 (with the
"standard" mirabox kernel 2.6.35.9).

For anyone who wants to
compile the kernel, be aware it works with a device tree. Since Mirabox
u-boot is quite old, you cannot use it directly. This is what I did to
get a working uImage:
cp arch/arm/boot/zImage .
cp arch/arm/boot/dts/armada-370-mirabox.dtb .
cat zImage armada-370-mirabox.dtb > zImage-mirabox
mkimage -A arm -O linux -T kernel -C none -a 0x00008000 -e 0x00008000 -n
linux-3.9-rc6 -d zImage-mirabox uImage

If anyone wants to proceed with this, please feel free to do so! And please
post your findings back here. --
To unsubscribe, e-mail: opensuse-arm+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-arm+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages