Mailinglist Archive: opensuse-arm (74 mails)

< Previous Next >
Re: [opensuse-arm] openSUSE on Beagleboard xM
  • From: Guillaume Gardet <guillaume.gardet@xxxxxxx>
  • Date: Wed, 29 Feb 2012 20:26:03 +0100
  • Message-id: <>

Le 27/02/2012 22:01, Alexander Graf a écrit :
On 27.02.2012, at 20:05, Guillaume Gardet wrote:

No. My previous trick no more works.
Well, I tried another thing. I dd if=/dev/zero to erase the first sectors to
be sure to have a good card to start and then dd the raw image. Then I tried
to boot and get a "60" on the serial port which means no suitable MLO where
found where it is ecpected!
Hrm - weird. Could you please try to dd if=/dev/zero the first couple MB and
then just dd MLO straight into offset 128kb? Try again for offset 0.

With openSUSE MLO it boots something (since it does not try UART boot, which
print 60) but nothing is printed on screen (crash?). With the openSUSE sources
and patches with a code sourcery toolchain, I get a running MLO. So, it should
be a problem with the toolchain or some optimisations flag (which are not
supported by beagleboard?).
Could you please provide the full compilation line to see what flags could lead
to problems?

Or maybe did you use the pandaboard MLO instead of the beagle MLO? That could
explain why it start to boot but crash.

Note that u-boot.bin do not boot either. It seems I cannot download
u-boot-linaro-20111213.tar.bz2 from
to try to build it. COuld you please tell me where I can download it?


To unsubscribe, e-mail: opensuse-arm+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-arm+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups