Mailinglist Archive: libyui-commit (19 mails)

< Previous Next >
[libyui-commit] Build failed in Jenkins: libyui-test-qt-master #102
  • From: admin@xxxxxxxxxxxx
  • Date: Wed, 17 Apr 2019 17:01:57 +0000 (UTC)
  • Message-id: <254895055.8.1555520517782.JavaMail.jenkins@ci-opensuse>
See <http://ci.opensuse.org/job/libyui-test-qt-master/102/display/redirect>

------------------------------------------
[...truncated 15.94 KB...]
[ 9s] [101/222] cumulate libxcb-xinput0-1.13-2.3
[ 9s] [102/222] cumulate libxcb-xkb1-1.13-2.3
[ 9s] [103/222] keeping libX11-6-1.6.7-1.2
[ 9s] [104/222] keeping libasan5-8.3.1+r269200-1.1
[ 9s] [105/222] keeping libdb-4_8-4.8.30-37.5
[ 9s] [106/222] keeping libfdisk1-2.33.1-2.1
[ 9s] [107/222] keeping libgobject-2_0-0-2.60.0-1.1
[ 9s] [108/222] keeping liblsan0-8.3.1+r269200-1.1
[ 9s] [109/222] keeping libmodman1-2.0.1-18.3
[ 9s] [110/222] keeping libmount1-2.33.1-2.1
[ 9s] [111/222] keeping libmpc3-1.1.0-1.9
[ 9s] [112/222] keeping libtsan0-8.3.1+r269200-1.1
[ 9s] [113/222] keeping libubsan1-8.3.1+r269200-1.1
[ 9s] [114/222] keeping libyui10-3.5.0-1.1
[ 9s] [115/222] cumulate libyui9-3.4.2-2.2
[ 9s] [116/222] keeping libboost_test1_69_0-1.69.0-1.2
[ 9s] [117/222] keeping libfreetype6-2.9.1-3.1
[ 9s] [118/222] keeping libgbm1-19.0.1-217.1
[ 9s] [119/222] keeping libsemanage1-2.9-1.1
[ 9s] [120/222] keeping libXdamage1-1.1.5-1.1
[ 9s] [121/222] keeping libXext6-1.3.4-1.1
[ 9s] [122/222] keeping libXfixes3-5.0.3-1.5
[ 9s] [123/222] keeping libXrender1-0.9.10-1.6
[ 9s] [124/222] keeping libglvnd-1.1.1-1.1
[ 9s] [125/222] cumulate libxcb-render-util0-0.3.9-3.11
[ 9s] [126/222] keeping libXfont2-2-2.0.3-2.5
[ 9s] [127/222] cumulate libgudev-1_0-0-232-2.3
[ 9s] [128/222] keeping libharfbuzz0-2.3.1-1.2
[ 9s] [129/222] keeping libproxy1-0.4.15-5.2
[ 9s] [130/222] cumulate libxcb-image0-0.4.0-1.12
[ 9s] [131/222] keeping cpp8-8.3.1+r269200-1.1
[ 9s] [132/222] keeping perl-5.28.1-2.2
[ 9s] [133/222] keeping brp-check-suse-84.87+git20181106.224b37d-1.1
[ 9s] [134/222] keeping libXxf86vm1-1.1.4-1.11
[ 9s] [135/222] cumulate libwacom2-0.32-1.1
[ 9s] [136/222] keeping Mesa-libEGL1-19.0.1-217.1
[ 9s] [137/222] cumulate libinput10-1.13.1-1.1
[ 9s] [138/222] keeping terminfo-base-6.1-14.1
[ 9s] [139/222] keeping libelf1-0.176-1.1
[ 9s] [140/222] keeping libfontconfig1-2.13.1-2.1
[ 9s] [141/222] keeping Mesa-libGL1-19.0.1-217.1
[ 9s] [142/222] keeping dwz-0.12-6.1
[ 9s] [143/222] keeping fontconfig-2.13.1-2.1
[ 9s] [144/222] keeping libebl-plugins-0.176-1.1
[ 9s] [145/222] keeping Mesa-19.0.1-217.1
[ 9s] [146/222] keeping libncurses6-6.1-14.1
[ 9s] [147/222] keeping libdw1-0.176-1.1
[ 9s] [148/222] keeping libreadline8-8.0-1.2
[ 9s] [149/222] keeping ncurses-utils-6.1-14.1
[ 9s] [150/222] keeping bash-5.0-6.1
[ 9s] [151/222] keeping cpp-8-2.4
[ 9s] [152/222] keeping bzip2-1.0.6-43.5
[ 9s] [153/222] keeping cracklib-2.9.6-2.9
[ 9s] [154/222] keeping gettext-runtime-mini-0.19.8.1-11.1
[ 9s] [155/222] keeping xz-5.2.4-1.5
[ 9s] [156/222] keeping info-6.5-6.6
[ 9s] [157/222] keeping iproute2-4.20-1.1
[ 9s] [158/222] keeping cpio-2.12-6.5
[ 9s] [159/222] keeping diffutils-3.7-1.2
[ 9s] [160/222] keeping gzip-1.10-1.5
[ 9s] [161/222] keeping libcrack2-2.9.6-2.9
[ 9s] [162/222] keeping make-4.2.1-7.5
[ 9s] [163/222] keeping which-2.21-4.9
[ 9s] [164/222] keeping findutils-4.6.0-4.5
[ 9s] [165/222] keeping gawk-4.2.1-1.12
[ 9s] [166/222] keeping gettext-tools-mini-0.19.8.1-11.1
[ 9s] [167/222] keeping grep-3.3-2.1
[ 9s] [168/222] keeping tar-1.31-1.1
[ 9s] [169/222] keeping binutils-2.32-3.1
[ 9s] [170/222] keeping sed-4.7-1.1
[ 9s] [171/222] keeping coreutils-8.31-1.2
[ 9s] [172/222] keeping systemd-rpm-macros-4-2.1
[ 9s] [173/222] keeping linux-glibc-devel-5.0-1.1
[ 9s] [174/222] keeping glibc-locale-base-2.29-5.1
[ 9s] [175/222] keeping xkeyboard-config-2.23.1-1.3
[ 9s] [176/222] cumulate timezone-2019a-1.1
[ 9s] [177/222] keeping permissions-20190212-1.1
[ 9s] [178/222] keeping krb5-mini-1.17-1.1
[ 9s] [179/222] keeping rpm-4.14.2.1-4.1
[ 9s] [180/222] keeping glibc-locale-2.29-5.1
[ 9s] [181/222] keeping libxkbcommon0-0.8.4-1.1
[ 9s] [182/222] keeping rpm-config-SUSE-0.g11-1.1
[ 9s] [183/222] keeping libtirpc3-1.0.3-3.1
[ 9s] [184/222] keeping libxkbfile1-1.1.0-1.1
[ 9s] [185/222] keeping glibc-devel-2.29-5.1
[ 9s] [186/222] cumulate libicu-suse64_1-64.1-1.1
[ 9s] [187/222] keeping rpmlint-mini-1.10-8.12
[ 9s] [188/222] keeping build-compare-20190219T103140.3277313-1.1
[ 9s] [189/222] keeping rpmlint-Factory-1.0-94.2
[ 9s] [190/222] keeping libnsl2-1.2.0-2.9
[ 9s] [191/222] keeping libstdc++6-devel-gcc8-8.3.1+r269200-1.1
[ 9s] [192/222] keeping xkbcomp-1.4.2-1.3
[ 9s] [193/222] cumulate libxkbcommon-x11-0-0.8.4-1.1
[ 9s] [194/222] cumulate libQt5Core5-5.12.2-1.2
[ 9s] [195/222] keeping gcc8-8.3.1+r269200-1.1
[ 9s] [196/222] keeping libstdc++-devel-8-2.4
[ 9s] [197/222] keeping gcc-8-2.4
[ 9s] [198/222] cumulate libQt5DBus5-5.12.2-1.2
[ 9s] [199/222] keeping gcc8-c++-8.3.1+r269200-1.1
[ 9s] [200/222] keeping pam-1.3.1-2.5
[ 9s] [201/222] keeping xorg-x11-server-1.20.4-2.1
[ 9s] [202/222] keeping gcc-PIE-8-2.4
[ 9s] [203/222] keeping gcc-c++-8-2.4
[ 9s] [204/222] keeping libboost_headers1_69_0-devel-1.69.0-1.2
[ 9s] [205/222] cumulate libQt5Network5-5.12.2-1.2
[ 9s] [206/222] keeping shadow-4.6-3.5
[ 9s] [207/222] keeping libboost_headers-devel-1.69.0-1.1
[ 9s] [208/222] keeping libboost_test1_69_0-devel-1.69.0-1.2
[ 9s] [209/222] keeping sysuser-shadow-2.0-2.12
[ 9s] [210/222] cumulate libQt5Gui5-5.12.2-1.2
[ 9s] [211/222] keeping libboost_test-devel-1.69.0-1.1
[ 9s] [212/222] cumulate libQt5X11Extras5-5.12.2-1.1
[ 9s] [213/222] keeping system-group-hardware-20170617-7.1
[ 9s] [214/222] cumulate libQt5Widgets5-5.12.2-1.2
[ 9s] [215/222] keeping libutempter0-1.1.6-10.9
[ 9s] [216/222] keeping libyui-devel-3.5.0-1.1
[ 9s] [217/222] cumulate libyui-qt9-2.49.16-1.1
[ 9s] [218/222] keeping util-linux-2.33.1-2.1
[ 9s] [219/222] keeping aaa_base-84.87+git20190404.8684de3-1.1
[ 9s] [220/222] keeping rpm-build-4.14.2.1-4.1
[ 9s] [221/222] keeping aaa_base-malloccheck-84.87+git20190404.8684de3-1.1
[ 9s] [222/222] keeping post-build-checks-84.88+git20181015.ceb5c96-1.2
[ 9s] now installing cumulated packages
[ 9s] Preparing...
########################################
[ 9s] Updating / installing...
[ 9s] libxcb-xkb1-1.13-2.3
########################################
[ 10s] libmtdev1-1.1.5-1.16
########################################
[ 10s] libICE6-1.0.9-4.5
########################################
[ 10s] libSM6-1.2.3-1.2
########################################
[ 10s] libxkbcommon-x11-0-0.8.4-1.1
########################################
[ 10s] timezone-2019a-1.1
########################################
[ 10s] libgudev-1_0-0-232-2.3
########################################
[ 10s] libxcb-render-util0-0.3.9-3.11
########################################
[ 11s] libyui9-3.4.2-2.2
########################################
[ 11s] libxcb-xinput0-1.13-2.3
########################################
[ 11s] libxcb-xinerama0-1.13-2.3
########################################
[ 11s] libxcb-util1-0.4.0-1.12
########################################
[ 11s] libxcb-image0-0.4.0-1.12
########################################
[ 11s] libxcb-shape0-1.13-2.3
########################################
[ 11s] libxcb-randr0-1.13-2.3
########################################
[ 11s] libxcb-keysyms1-0.4.0-1.11
########################################
[ 12s] libxcb-icccm4-0.4.1-4.6
########################################
[ 12s] libdouble-conversion2-3.0.3-1.1
########################################
[ 12s] libts0-1.16-1.3
########################################
[ 12s] libpcre2-16-0-10.32-3.2
########################################
[ 12s] libevdev2-1.4.5-2.12
########################################
[ 12s] libwacom-data-0.32-1.1
########################################
[ 12s] libwacom2-0.32-1.1
########################################
[ 12s] libinput10-1.13.1-1.1
########################################
[ 14s] libicu64_1-ledata-64.1-1.1
########################################
[ 14s] libicu-suse64_1-64.1-1.1
########################################
[ 15s] libQt5Core5-5.12.2-1.2
########################################
[ 15s] libQt5DBus5-5.12.2-1.2
########################################
[ 15s] libQt5Network5-5.12.2-1.2
########################################
[ 16s] libQt5Gui5-5.12.2-1.2
########################################
[ 17s] libQt5X11Extras5-5.12.2-1.1
########################################
[ 17s] libQt5Widgets5-5.12.2-1.2
########################################
[ 17s] libyui-qt9-2.49.16-1.1
########################################
[ 18s] removing nis flags from
/var/tmp/build-root/openSUSE_Factory-x86_64/etc/nsswitch.conf...
[ 18s] now finalizing build dir...
[ 19s] -----------------------------------------------------------------
[ 19s] I have the following modifications for libyui-test-qt.spec:
[ 19s] 21c21
[ 19s] < Release: 0
[ 19s] ---
[ 19s] > Release: 1
[ 19s] -----------------------------------------------------------------
[ 19s] ----- building libyui-test-qt.spec (user abuild)
[ 19s] -----------------------------------------------------------------
[ 19s] -----------------------------------------------------------------
[ 19s] + exec rpmbuild -ba --define '_srcdefattr (-,root,root)' --nosignature
/home/abuild/rpmbuild/SOURCES/libyui-test-qt.spec
[ 19s] setting SOURCE_DATE_EPOCH=1477051200
[ 19s] Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.eLRkPP
[ 19s] + umask 022
[ 19s] + cd /home/abuild/rpmbuild/BUILD
[ 19s] + cd /home/abuild/rpmbuild/BUILD
[ 19s] + rm -rf libyui-test-1.0.8
[ 19s] + /usr/bin/bzip2 -dc
/home/abuild/rpmbuild/SOURCES/libyui-test-1.0.8.tar.bz2
[ 19s] + /usr/bin/tar -xof -
[ 19s] + STATUS=0
[ 19s] + '[' 0 -ne 0 ']'
[ 19s] + cd libyui-test-1.0.8
[ 19s] + /usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
[ 19s] + exit 0
[ 19s] Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.sQqdz4
[ 19s] + umask 022
[ 19s] + cd /home/abuild/rpmbuild/BUILD
[ 19s] + /usr/bin/rm -rf
/home/abuild/rpmbuild/BUILDROOT/libyui-test-qt-1.0.8-1.x86_64
[ 19s] ++ dirname
/home/abuild/rpmbuild/BUILDROOT/libyui-test-qt-1.0.8-1.x86_64
[ 19s] + /usr/bin/mkdir -p /home/abuild/rpmbuild/BUILDROOT
[ 19s] + /usr/bin/mkdir
/home/abuild/rpmbuild/BUILDROOT/libyui-test-qt-1.0.8-1.x86_64
[ 19s] + cd libyui-test-1.0.8
[ 19s] + make check 'CXXFLAGS=-O2 -Wall -D_FORTIFY_SOURCE=2
-fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables
-fstack-clash-protection' TARGETS=qt
[ 19s] g++ -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong
-funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection
-I/usr/include/yui -std=c++0x -L/usr/lib64 dialog_cleanup_test.cc -lyui -o
dialog_cleanup_test
[ 20s] g++ -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong
-funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection
-I/usr/include/yui -std=c++0x -L/usr/lib64 input_field_test.cc -lyui -o
input_field_test
[ 21s] g++ -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong
-funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection
-I/usr/include/yui -std=c++0x -L/usr/lib64 library_shutdown_test.cc -lyui -o
library_shutdown_test
[ 21s] g++ -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong
-funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection
-I/usr/include/yui -std=c++0x -L/usr/lib64 tree_item_selection_test.cc -lyui
-o tree_item_selection_test
[ 22s] LD_LIBRARY_PATH=/usr/lib64 TARGETS="qt" ./test_all dialog_cleanup_test
library_shutdown_test tree_item_selection_test
[ 22s] + set -u
[ 22s] + TERM_FOR_ncurses=./virtual_terminal
[ 22s] + TERM_FOR_qt=./virtual_x_server
[ 22s] + TERM_FOR_gtk=./virtual_x_server
[ 22s] + : qt
[ 22s] + FAIL=false
[ 22s] + for UI in $TARGETS
[ 22s] + TERM_FOR_UI=TERM_FOR_qt
[ 22s] + ./virtual_x_server './test_qt dialog_cleanup_test
library_shutdown_test tree_item_selection_test 2> qt.log'
[ 22s] + export DISPLAY=:9
[ 22s] + DISPLAY=:9
[ 22s] + PID=4809
[ 22s] + Xvfb :9 -screen 0 1024x768x24
[ 22s] + sleep 1
[ 23s] + eval './test_qt dialog_cleanup_test library_shutdown_test
tree_item_selection_test 2> qt.log'
[ 23s] ++ ./test_qt dialog_cleanup_test library_shutdown_test
tree_item_selection_test
[ 23s] + RET=134
[ 23s] + kill 4809
[ 23s] + exit 134
[ 23s] + tail qt.log
[ 23s] <_M_> [ui] YSettings.cc:74 progDir(): progDir: ""
[ 23s] <_M_> [ui] YPath.cc:65 YPath(): Preferring subdir:
[ 23s] <_M_> [ui] YPath.cc:66 YPath(): Subdir given with filename:
[ 23s] <_M_> [ui] YPath.cc:67 YPath(): Looking for: libyui-qt.so.10
[ 23s] <_M_> [ui] YPath.cc:138 lsDir(): Looking in /usr/lib64/yui
[ 23s] <_M_> [ui] YPath.cc:121 YPath(): Could NOT find libyui-qt.so.10 by
looking recursive inside /usr/lib64/yui
[ 23s] <WRN> [ui] YUILoader.cc:168 loadUI(): THROW: No $DISPLAY and
stdout is not a tty
[ 23s] terminate called after throwing an instance of
'YUICantLoadAnyUIException'
[ 23s] what(): No $DISPLAY and stdout is not a tty
[ 23s] ./test_qt: line 4: 4813 Aborted (core dumped) ./$i
--qt
[ 23s] + FAIL=true
[ 23s] + true
[ 23s] make: *** [Makefile:53: check] Error 1
[ 23s] error: Bad exit status from /var/tmp/rpm-tmp.sQqdz4 (%build)
[ 23s]
[ 23s]
[ 23s] RPM build errors:
[ 23s] Bad exit status from /var/tmp/rpm-tmp.sQqdz4 (%build)
[ 23s]
[ 23s] yast-jenkins failed "build libyui-test-qt.spec" at Wed Apr 17 17:01:57
UTC 2019.
[ 23s]

The buildroot was: /var/tmp/build-root/openSUSE_Factory-x86_64
rm -rf devel:libraries:libyui
rake aborted!
Command failed with status (1): [yes | osc -A 'https://api.opensuse.org/' b...]

Tasks: TOP => osc:build
(See full trace by running task with --trace)
cleaning
Build step 'Execute shell' marked build as failure

< Previous Next >
This Thread
Follow Ups
References