Mailinglist Archive: kubic-bugs (110 mails)

< Previous Next >
[kubic-bugs] [Bug 1088488] New: proposal_runner.rb: "no implicit conversion of Array into String"
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 06 Apr 2018 14:12:34 +0000
  • Message-id: <bug-1088488-81400@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=1088488


Bug ID: 1088488
Summary: proposal_runner.rb: "no implicit conversion of Array
into String"
Classification: openSUSE
Product: openSUSE Tumbleweed
Version: Current
Hardware: Other
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: YaST2
Assignee: yast2-maintainers@xxxxxxx
Reporter: rbrown@xxxxxxxx
QA Contact: jsrain@xxxxxxxx
CC: knut.anderssen@xxxxxxxx, kubic-bugs@xxxxxxxxxxxx
Found By: ---
Blocker: ---

Created attachment 766316
--> http://bugzilla.suse.com/attachment.cgi?id=766316&action=edit
y2logs

As part of resolving https://bugzilla.suse.com/show_bug.cgi?id=1088456 I need
to use the network proposal module on the traditional openSUSE/SUSE
Installation Settings screen

Therefore I added the following to the Kubic control.xml in the appropriate
<proposal>

<proposal_module>
<name>network</name>
<presentation_order>40</presentation_order>
</proposal_module>

I expected this to call the existing network_proposal module

https://github.com/yast/yast-network/blob/master/src/lib/network/clients/network_proposal.rb

From my laymans eyes, it should work similar to other similar proposal modules,
even though it's never been used in that role before as it was originally part
of the custom CaaSP one screen install (which Kubic is investigating the
feasibility of replacing it with regular YaST modules)

This seems to be partially successful; when loading the Installation Settings
screen YaST clearly shows a section for "Network Configuration", strongly
suggesting this module is being loaded

But it then crashes with the following internal error:

"Details: no implicit conversion of Array into String
Caller:
/mounts/mp_0007/usr/share/YaST2/lib/installation/proposal_runner.rb:539:in
'format_sub_proposal'"

This means Kubic cannot currently use this module, as required.

y2logs attached

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >