17 Sep
2005
17 Sep
'05
12:48
On Fri, 16 Sep 2005 20:04:29 +0200 Anders Johansson <andjoh@rydsbo.net> wrote:
But I wouldn't include x++ in that definition The pre-increment/post-increment (and decrement) operators are not fancy code in C, they are an integral part of the language, but they are often misused.
I also do not consider this fancy code: int c; while( (c = getchar()) != EOF) { ... } Note that I generally try to compare vs. NULL or 0, for example: 'if (p == NULL)' rather than 'if (!p)' Both are correct in C, but the second is less readable. -- Jerry Feldman <gaf@blu.org> Boston Linux and Unix user group http://www.blu.org PGP key id:C5061EA9 PGP Key fingerprint:053C 73EC 3AC1 5C44 3E14 9245 FB00 3ED5 C506 1EA9