[opensuse-packaging] sharedlib names for wxWidget variants
The pkg wxsqlite3 adds the version of wxWidgets to its SONAME. This causes build failures because there is appearently no rpm macro for the used wxWidgets version. If the pkg name is hardcoded it will fail with old or upcoming wxWidgets versions. I wonder if wxsqlite3 or our packaging of wxWidgets is the culprit. Right now the subpkg is named "libwxcode_gtk2u_wxsqlite3-3_0-0", but it should be named "libwxcode_gtk2u_wxsqlite3-2_8-0" if built against wxWidgets-2.8. The SONAME looks like that, based on the m4 macro below: libwxcode_gtk2u_wxsqlite3-2.8.so.0()(64bit) libwxcode_gtk2u_wxsqlite3-3.0.so.0()(64bit) AC_DEFUN([WX_LIKE_LIBNAME], [ wx_temp="$2""_""$WX_PORT" dnl add the [u][d] string if test "$WX_UNICODE" = "1"; then wx_temp="$wx_temp""u" fi if test "$WX_DEBUG" = "1"; then wx_temp="$wx_temp""d" fi dnl complete the name of the lib wx_temp="$wx_temp""_""$3""-$WX_VERSION_MAJOR.$WX_VERSION_MINOR" dnl save it in the user's variable $1=$wx_temp ]) WX_LIKE_LIBNAME([WXSQLITE3_LIBNAME], [wxcode], [wxsqlite3]) How should this pkg deal with the SONAME? Remove the wxWidgets version and remove the ability that more than one wxWidgets version can be supported, or add code to the specile to decide at buildtime how the subpkg should be named? Thanks, Olaf
participants (1)
-
Olaf Hering