Mailinglist Archive: opensuse-kde (206 mails)

< Previous Next >
Re: [opensuse-kde] File conflict between kdelibs3 and kdelibs4
  • From: todd rme <toddrme2178@xxxxxxxxx>
  • Date: Thu, 29 Mar 2012 10:46:06 +0200
  • Message-id: <CADb7s=v4+X3zetciZAiAM+F-14DnwkqjXAmWak_fxGKoz3dgUQ@mail.gmail.com>
On Wed, Mar 28, 2012 at 8:57 PM, Markus <kamikazow@xxxxxx> wrote:
Am Mittwoch 28 März 2012, 17:04:18 schrieb Petr Mladek:

We need support for KDE4 because it is default on openSUSE. I removed
KDE3 support in the past but KDE3 users wanted it back. So, I accepted
submit request from Ilya and added it back. Thus we need both KDE3 and
KDE4 during build.

Whoever wants that should build that extension in the KDE3 repo. So please
remove the KDE3 extension from main LibreOffice. And while you're at it,
rename libreoffice-kde4 to libreoffice-kde. Plasma Desktop is default in
openSUSE, so if someone still wants KDE3 integration, should call it
libreoffice-kde3. KDE3 should not hijack the main "-kde" name.

I am not sure whether it should be moved, but I do think renaming both
to match KDE3/KDE4 packaging conventions makes sense to me.

-Todd
--
To unsubscribe, e-mail: opensuse-kde+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-kde+owner@xxxxxxxxxxxx

< Previous Next >