Mailinglist Archive: zypp-commit (301 mails)

< Previous Next >
[zypp-commit] r7603 - in /trunk/sat-solver/testsuite: README.FAILS data.libzypp/yast-tests/exercise-02conflict-12-test.solution data.libzypp/yast-tests/exercise-02conflict-system.solv data.libzypp/yast-tests/ignore
  • From: coolo@xxxxxxxxxxxxxxxx
  • Date: Tue, 23 Oct 2007 08:41:30 -0000
  • Message-id: <20071023084130.4F2352D135@xxxxxxxxxxxxxxxx>
Author: coolo
Date: Tue Oct 23 10:41:29 2007
New Revision: 7603

URL: http://svn.opensuse.org/viewcvs/zypp?rev=7603&view=rev
Log:
the problem mls saw is not the problem (proving by updating
solv file). But the test case clearly says that the upgrade should
not happen, but libzypp still upgrades -> ignoring

Modified:
    trunk/sat-solver/testsuite/README.FAILS
    trunk/sat-solver/testsuite/data.libzypp/yast-tests/exercise-02conflict-12-test.solution
    trunk/sat-solver/testsuite/data.libzypp/yast-tests/exercise-02conflict-system.solv
    trunk/sat-solver/testsuite/data.libzypp/yast-tests/ignore

Modified: trunk/sat-solver/testsuite/README.FAILS
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/README.FAILS?rev=7603&r1=7602&r2=7603&view=diff
==============================================================================
--- trunk/sat-solver/testsuite/README.FAILS (original)
+++ trunk/sat-solver/testsuite/README.FAILS Tue Oct 23 10:41:29 2007
@@ -7,10 +7,6 @@
 ./data.libzypp/bugzilla-tests/bug308098-test.xml
        installs recommends
 
-./data.libzypp/yast-tests/exercise-02conflict-12-test.xml
-       very strange testcase, has two identical versions of requirerer2
-       installed and tests that the solver replaces just one, which
-       is actually impossible
 ./data.libzypp/kernel-tests/kernel_kmp-test.xml
        libzypp does an upgrade of a package needed, mls prefers not to
 

Modified: trunk/sat-solver/testsuite/data.libzypp/yast-tests/exercise-02conflict-12-test.solution
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/yast-tests/exercise-02conflict-12-test.solution?rev=7603&r1=7602&r2=7603&view=diff
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/yast-tests/exercise-02conflict-12-test.solution (original)
+++ trunk/sat-solver/testsuite/data.libzypp/yast-tests/exercise-02conflict-12-test.solution Tue Oct 23 10:41:29 2007
@@ -1,4 +1,27 @@
+Load from File './exercise-02conflict-system.xml.gz'
+Added repository '@system' with 19 resolvables
+Loaded 19 resolvables from exercise-02conflict-system.xml.gz.
+Load from File './exercise-02conflict-packages.xml.gz'
+Added repository 'test' with 25 resolvables
+Loaded 25 resolvables from exercise-02conflict-packages.xml.gz.
+
+------------------------------------------------
+
 >!> Installing required2 from channel test
+
+Completed solutions: 1
+Pruned solutions: 0
+Deferred solutions: 0
+Invalid solutions: 0
+
+Best Solution:
 >!> Solution #1:
+Checksum = 33cd2a38
 >!> upgrade required2-1.0-1.noarch => required2-2.0-1.noarch[test]
 >!> installs=0, upgrades=1, uninstalls=0
+download size=0.0k, install size=18014398509481984.0k
+total priority=0, min priority=0, max priority=0
+other penalties=0
+- - - - - - - - - -
+Context Info:
+

Modified: trunk/sat-solver/testsuite/data.libzypp/yast-tests/exercise-02conflict-system.solv
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/yast-tests/exercise-02conflict-system.solv?rev=7603&r1=7602&r2=7603&view=diff
==============================================================================
Binary files - no diff available.

Modified: trunk/sat-solver/testsuite/data.libzypp/yast-tests/ignore
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/yast-tests/ignore?rev=7603&r1=7602&r2=7603&view=diff
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/yast-tests/ignore (original)
+++ trunk/sat-solver/testsuite/data.libzypp/yast-tests/ignore Tue Oct 23 10:41:29 2007
@@ -14,3 +14,5 @@
 #packages without version are broken packages
 # -> invalid test
 exercise-kdelibsobs-force-test.xml
+# libzypp is not doing what the test case is describing
+exercise-02conflict-12-test.xml

--
To unsubscribe, e-mail: zypp-commit+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: zypp-commit+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages